Windows 7

I have Kaspersky Internet Security 2009 which was earlier installed on windows vista and has 100 days validity period left but now I have installed windows 7 and would like to install KIS 2009 on windows 7. The problem is that while installing KIS 2009 I got an error message that it is incompatible with windows 7.

Please help me on this.
1 answer Last reply
More about windows
  1. Upgrade to 2010. Alternatively, use Windows Security Essentials and Window Firewall for free.
Ask a new question

Read More

Drivers Windows 7 Internet Security Windows Vista Kaspersky