Sign in with
Sign up | Sign in
Your question

USB Flash Drive Error/Unable to Open

Last response: in Storage
Share
November 1, 2011 12:21:21 AM

Hi Tom's Hardware forumers,

I have the USB DataTraveler 101 Generation 2 (G2) 16 GB from Kingston that now cannot be read/open by any computer. This USB is farely new, i have been using it for only a few months (i bought it brand new), and just today morning when i plugged it in the computer nothing popped up (usually windows explorer), and i went to my computer and only saw Removable Drive F. It is usually read as Kingston Flash Drive and have thumbnail but now it just says removable drive. So i went ahead and opened it up and the message popped up saying "Disk is not formatted. The disk in drive F is not formatted. Do you want to format it? Yes or No". I thought it was just my work computer but when i went to my home computer, the same thing happened. I have valuable data in there that is really important and so i do not want to format it. My USB is still under warranty by Kingston but i don't know if its just a USB bug or a serious hardware problem. Is there a way to get my USB back to working normally and accessing my files? If not is there anyway to recover all my data from my USB? I will format it but only after i get all my data out. When i right click removal drive F, it says the system file is RAW. I never seen such thing, i remember it originally was FAT32.

Please help me with this, i do need some of the data in it urgently.
Thanks in advance to all
November 1, 2011 6:58:54 PM

i just tried recuva but the thing is that, it cannot access in the usb. i can't even go in the usb from "My computer" so recuva also can't access it either. when i run recuva it says unable to determine file system type :S
Related resources
a c 354 G Storage
November 2, 2011 11:30:15 AM

I suggest you try contacting Kingston. It's possible that the drive simply failed.
February 21, 2013 11:39:53 PM

How does it show in "Disk management"?
Perhaps, it need you to assign a new letter for it.
October 1, 2013 12:05:43 AM

its aint data recovery problem.its about a new kind of unknown error.
when i connect usb flash drive to my computer,then my computer recognize as usb drive.
but when i click on this drive .it gives following error message,The disk in drive E is not formatted.
Do you want to format it nowe?
Yes Now

when someone click on Yes,then Format Removable Disk E dialog box appears.when someone click the format dialog box's
start button, a dialog box with a Warning appears.Warning Formatting will erase all data on the disk.To Format the
disk,click ok.To quit,click cancel.
ok Cancel
when someone click on ok, a dialog box appears.displaying following message,
Windows was unable to complete the format.OK

my friends what is solution of this problem?How to format This kind of USB Flasah Drive,which is
relatively new.
October 14, 2013 7:02:09 AM

moneyonone said:
Hi Tom's Hardware forumers,

I have the USB DataTraveler 101 Generation 2 (G2) 16 GB from Kingston that now cannot be read/open by any computer. This USB is farely new, i have been using it for only a few months (i bought it brand new), and just today morning when i plugged it in the computer nothing popped up (usually windows explorer), and i went to my computer and only saw Removable Drive F. It is usually read as Kingston Flash Drive and have thumbnail but now it just says removable drive. So i went ahead and opened it up and the message popped up saying "Disk is not formatted. The disk in drive F is not formatted. Do you want to format it? Yes or No". I thought it was just my work computer but when i went to my home computer, the same thing happened. I have valuable data in there that is really important and so i do not want to format it. My USB is still under warranty by Kingston but i don't know if its just a USB bug or a serious hardware problem. Is there a way to get my USB back to working normally and accessing my files? If not is there anyway to recover all my data from my USB? I will format it but only after i get all my data out. When i right click removal drive F, it says the system file is RAW. I never seen such thing, i remember it originally was FAT32.

Please help me with this, i do need some of the data in it urgently.
Thanks in advance to all

The usb flash drive is definitely corrupted. Firstly, you'd better backup all the data on the usb flash drive, follow this step by step guide if you do not know how: backup data from corrupted flash drive

After you get back all your data, you can try to format the memory card. right click and do a low level format. Follow this guide if you do not know how
http://windows.microsoft.com/en-sg/windows-vista/format...

Another possible reason that the usb flash drive not able to open is virus. So you'd better run a virus scan software, you may try this one
http://mayshare.is3.revenuewire.net/stopzillaav/downloa...



contact Kingson support. It may also be infected by virus.
December 11, 2013 4:15:34 AM

I have the same problem with my Sony Vaio laptop... the issue does not appear to be a hardware problem. Windows recognizes each different USB device, even assigns a drive letter... but won't access the content. It also says to format the drive but when I try it on known blank drives it comes back and says it cannot format. I have disabled/uninstalled all USB drivers / Hub in the control panel to have windows reinstall them on a reboot...but no success. It almost seems as if the Windows software is missing some key element that allows it to read content on USB drives. The weird thing is that until a couple of months ago the laptop worked just perfectly. Haven't been able to narrow down the problem yet.
!