Sign in with
Sign up | Sign in
Your question

Graphical/peformance problems with HD 4770

Last response: in Graphics & Displays
Share
December 3, 2009 9:13:17 AM

Ok,

I thought I would post this as it is a problem that I experienced and it took a LONG time to sort it out! ATI where stumped and I tried a lot of solutions that did not work.

First let me describe the problems (there where two). First of all after proper installation of the HD 4770 I was unable to install the latest version of Catalyst Control Centre (v9.11). Every time I tried it would crash my computer during installation at exactly the same point! This problem ended up being solved by running a repair installation of windows XP and updating to service pack 3. After this the installation ran just fine.

However, the biggest problem was that although my system was reading the card and not registering any problems, it was in fact not using the card properly. During any application requiring graphic operation (I’m talking anything from video streaming to game play) there where problems.

Gaming was the most noticeable. Playing most games I was experiencing massive graphical glitches/artefacts. Textures in game where being stretched out across the screen or becoming invisible, portions of the game maps became totally black, or random blocks of textures where stretching off like sky scrapers into the sky! Other games showed massive areas of polygons instead of what was meant to be there. During video streaming I experienced what looked like interlacing problems and display cut-outs with a message saying that the GPU had not being responding so had been reset, and then next time crashed the computer.

There seemed to be no reason for this to be happening, and after hours of correspondence with ATI they had no idea of why it would be happening, so sent a description of the issue off to their offices in Canada and didn’t hear back.

What I tried in order to solve the problem:
*uninstalling/reinstalling drivers.
*rolling back to older driver versions.
*Checking bios settings.
*Double checking all connections
*repair install xp and update to SP3.
*running full virus scan.
*resetting CMOS to set processor back to factory clock.
*Unplugging all devices attached to PSU except GPU and those necessary to running
*underclocking GPU
*updating VIA chipset drivers
*Flashing bios to most recent version
*shouting at it

None of these things worked. By this time I had decided that it was a problem with the motherboard and contacted AROCK directly with a description of the problem. They emailed me a non released version of the BIOS for my board. Version available on the website was V2.3 and they sent me V2.39a. So I flashed this version (which required me "obtaining" a floppy drive, ribbon cable and disks from work and borrowing a PS2 keyboard from a shop down the road!). I did this with my old graphics card in place and afterwards uninstalled it and put in the new one.

Low and behold this solved the problem!
Now it works just fine.

Sorry for the LONG essay, but I could find anything about this kind of problem listed ANYWHERE so I just want to give a good description for anyone else experiencing this kind of issue!

Hope it becomes helpful to someone.
December 3, 2009 12:40:32 PM

Thanks for sharing. I would have thought it was a bad video card.

Next time you might be more comfortable using a CD to flash the bios.

Create BIOS Update CD

http://www.bay-wolf.com/bootcd-bios.htm
December 3, 2009 1:24:04 PM

yeah i did concider the card might be broken, so i got a replacement and had the same problem. hence i knew it was something else.

As for the boot CD I later realised this was an option but had disconected the CD burner as part of my process of illimination, and in the end it was easier to just use the floppy drive.

thanks for your input.
Related resources
December 3, 2009 2:06:15 PM

Was this XP32 bit ? I'm thinking a switch to vista/7 64 bit might have done the trick. I have heard of problems with 5 series cards/new ati drivers and xp 32 bit. There is going to be less and less "backward" comparability as XP ages IMO.
December 4, 2009 10:43:42 AM

yeah its 32bit version. I am also thinking of upgrading soon too. mainly because i never used Vista and i dont want to get left behind! but also to used DX10/11 etc.
December 27, 2009 11:00:51 AM

Hey jayw84,

I have been having the EXACT same problem as you, and I will not waste time telling you how much effort I have wasted on other ideas.

Could you please send my a copy of the 2.39a bios and a rough guide on how to install it? I fear not doing it properly. And I am desperate to just play games without the horrible glitching.
!