Sign in with
Sign up | Sign in
Your question

[Solved]Hard drive only showing half capacity after formatting

Last response: in Storage
Share
November 1, 2011 3:18:17 PM

I am putting together a linux system for my kids using spare parts from an old HP pavilion. Right now I have the computer running windowsXP, and I was attempting to clean up an old Samsung sv0602h 60gb hard drive to use as the linux system drive.

I reformatted the drive with the windowsXP admin tools, and the drive size fell to 31.49gb. Both the bios and windows only show this new size. After a little research I discovered that I had moved the jumpers on the drive to limit it to 32gb, but after setting the correct jumps to allow the full 60gb, it is still showing up as a 31.49gb drive.

My understanding is that a reinstall of windowsXP will correct this issue, but I'm working with an old HP, scrap parts, OEM windows and no disks.

The drive is currently blank and formatted, if I start a linux install on it will that re-size it, or is there another option available to me?

Thanks for any tips or advice.
November 1, 2011 3:29:53 PM

In Windows you should be able to use the Disk management utility to Reformat the drive now that the drive is set to the full 60 GB.

To get to this right Click on My computer and select manage, then the Disk management utility in here, it should see both parts of the drive, 31.49 and the remaining, as separate drives. You will need to change this to dynamic and then add the two drives as one volume. You should be able to format this drive then.

Otherwise you should be able to use a linux live CD to format the drive.
November 1, 2011 3:30:50 PM

Did you format it after you moved the jumpers?

I don't know about linux but Windows gives you the option to format during the install, so there's really no reason to use admin tools.
Related resources
November 1, 2011 3:41:31 PM

I've tried using the Disk management utility to format it again and even tried deleting the partition and creating a new one, but it still shows 31.49gb. It never did show as two separate drives, even after resetting the jumpers.

I guess I'll give the linux install a try and hope to get back to 60gb.

Thanks for the replies.
November 8, 2011 3:45:08 PM

Sorry, after a couple hours of my life wasted, I realized the jumper diagram I was looking at was... uhhmm.... upside down. Or rather my hard drive was..., whatever.

Curse you samsung for your 8 pin, 2 jumper, configuration.

Anyways, oddly enough, when I put the jumpers in the correct position everything worked fine.
October 5, 2012 8:46:06 AM

Hey anowis 213 I have gone through same situation my HDD was 500 GB.
I formatted HDD in 32 GB mode then realised shifted jumper but now its showing 250 GB only can you suggest me something
!