Sign in with
Sign up | Sign in
Your question

4870HD running warcraft at 31FPS...no!

Last response: in Graphics & Displays
Share
December 4, 2009 9:04:05 AM

Hey guys,

I am having some FPS issues...31FPS is definitely wrong

Here is my rig info:

AMD Phenom II x4 955 BE
Gigabyte MA790FXT
4GB OCZ DDR3 PC3-12800 RAM
Radeon 4870HD
Crucial M225 SSD

Nothing is overclocked - the system runs stable as far as I know (no artifacts or freezes)

Running windows 7 x64 fully updated RTM
Eset nod32
World of Warcraft

Using 9.11 Catalyst ATI suite

I saw that my FPS was at 31FPS - and I know that it should be way higher with my system. I thought this was a driver issue and upgraded from 9.10 to 9.11 and did a driver sweep in between. The only thing that I think could be interfering with this is possibly that windows 7 loads a default driver for the display adapter. Although I really don't think it's the issue.

I have the game running in full-screen 1680x1050. Mutli-sampling at 1x effects at ultra.

At first I thought - it must be that I'm running the game at ultra. So I set it to low (lowest for all) and restarted WoW. Much to my dismay the FPS was still sitting at about 31FPS. +/- 1FPS

I have loaded GPU-Z to see if maybe the card wasn't using 3D; but lo-and-behold the core frequency jumps from 500Mhz to 750Mhz when I start WoW. (I have two monitors running)

I am totally lost - and would like to know what is going on here if only for peace of mind.

Thank you for any valuable input!

More about : 4870hd running warcraft 31fps

December 4, 2009 10:36:17 AM

I'm having the same issue.
I had the 8450 - thinking it was the card.. i upgraded to a Gainwood GTX285..
Still the same

Maybe it's an internet issue?... Anyone able to shead some light on this would get 10 internet points frome me.

Ty
m
0
l
December 4, 2009 11:01:10 AM

There are a lot of variables when talking game performance, but when you add online game performance, it gets a little crazy. If you want to check for the weakest link, try reducing graphical settings and see if performance improves. Also, depending on where you are taking these measurements and what you are doing at the time, performance will vary. Very 'busy' or complex areas will run slower than sparse ones. And finally, if you have vsync on it will reduce your FPS to whatever your monitor's refresh rate is. For example, if it is 60Hz and the card could do 100FPS, then it will reduce to 60FPS. If you drop to 56FPS though, then vsync will take it down to 30FPS (which could be your 31FPS). Check both in game settings and in Catalyst Control Center to see if this is on or forced on.
m
0
l
Related resources
December 4, 2009 11:02:43 AM

This might sounds silly but have you got Vsync enabled? (having not played WoW I don't know if its an option) but that tends to lock the FPS within a spcific range. On CSS i was stuck at 57-62fps which was very low for my system. Turned off Vsync and was getting 90-130fps straight away.
m
0
l
December 4, 2009 11:05:34 AM

Aslo might be worth checking your consol settings. You may have the max FPS set to 30. try changing it to a higher setting using:
/console maxfps 300
(for example)
m
0
l
December 4, 2009 1:42:48 PM

Ha. thats really funny. we both came up with similar solutions within seconds of each other! great minds...?
m
0
l
December 4, 2009 8:44:16 PM

Vsync isn't enabled....
For example (those wow heads should know what i'm talking about)

Im in Ironforge - and im getting 33fps - i go to the tinker town and im 170+

One min it's high, next it's rock bottom.... I'm constantly asking my friends there fps and it's more than double what i have on alot worste cards than mine...

(sorry to jack your threat) :-P
m
0
l
December 4, 2009 8:53:55 PM

What is your CPU, cyantific?
m
0
l
December 4, 2009 9:36:25 PM

It was the MaxFPS issue

setting

/console maxfps 1500

now gives me 700-900FPS when in the middle of nowhere and

200-500FPS when in the middle of org when it's packed.

Pretty big difference from 30FPS - lol!

Thanks guys!
m
0
l
December 5, 2009 3:47:06 PM

I have a quad core Q9400
m
0
l
Anonymous
December 6, 2009 8:24:04 PM

Maybe it's in relation to the new 3.3 patch they are rolling out? Also your shadows have a bit to do with it. Turn them down to the SECOND highest setting and you might have luck with that.
m
0
l
!