Sign in with
Sign up | Sign in
Your question

Dolby Digital Live X-fi

Last response: in Components
Share
February 12, 2010 10:52:00 PM

I purchased a x-fi Titanium Fatal1ty Professional sound card. I am running Windows 7 64 and I cannot get the Dolby Digital Live encoding to work for the life of me. The option is completely shaded out and says, "The Creative Audio Service is not started. Please reinstall the application." I have installed the drivers completely cleaned the old ones tried the newest drivers online and used Creative updater. I am using SPDIF with the fiber optic. Yes, my receiver does DTS and Dolby Digital. I have also reinstalled Dolby Digital Live and DTS connect pack with no luck.

http://i63.photobucket.com/albums/h158/DeathNeedle/Unti...

More about : dolby digital live

February 13, 2010 1:33:21 PM

the option for dts and ddl, in the screenshot u gave is not shaded out...
m
0
l
February 13, 2010 2:09:42 PM

Well, yes to be exact, but as you see the option does not allow me to use dts or ddl. Everytime I click on one it brings it back up to Off instantly, but thanks? :( 
m
0
l
Related resources
February 14, 2010 8:12:34 AM

thats really weird... tbf, im not sure i might be help, sorry

i guess the only thin u cuold try is w8 for a reply fromanother person, or check other forums out there.
m
0
l
February 14, 2010 1:24:27 PM

Try this driver set. As far as I can tell, you shouldn't have to pay extra to unlock DDL with a Titanium.
m
0
l
February 14, 2010 3:43:43 PM

I will try it and no you do not have to pay extra, but I did anyway -_-
m
0
l
February 14, 2010 4:48:53 PM

Well, now I can select the option under encoder and change the settings for DTS and DDL however when the encoder is on no audio under SPDIF is coming out for all videos music and games. When the encoder is off audio works.
m
0
l
February 14, 2010 4:56:32 PM

I don't know W7, but in Vista, you have to have "Speakers" selected as the default audio device in ControlPanel/Sound to get anything out of the SPDIF. For my card, anyway.
m
0
l
March 26, 2012 2:16:36 AM

Im not sure if this thread is still open but ill give it a shot...I had the same problem just a few days ago it was working fine till i placed the dot on turn off Dolby and the same thing happen to me nothing...how i fixed mine was i updated the drivers in my soundcard...after that i reinstalled the software and now its working fine
m
0
l
!