Sign in with
Sign up | Sign in
Your question

ATI X1950 CoD MW2

Last response: in Graphics & Displays
Share
December 5, 2009 2:16:00 AM

Hi, I'm kinda new here but I've used this site a decent amount to benchmark for certain GPU's / CPU's. I have an ATI Radeon X1950 graphics card, and when I play Modern Warfare 2, all the words are unreadable. I've looked around the internet for a solution, and noticed that alot of ATI users are having the same problem. I've updated my drivers, and still doesn't work. Does anyone have any ideas?
Thanks in advance!!!

More about : ati x1950 cod mw2

a b U Graphics card
December 5, 2009 2:38:00 AM

What resolution are you using in game and your monitors native resolution? Are you using an AA?
m
0
l
December 5, 2009 3:34:38 PM

Not trying to be a smart ass or anything, but like I said, I cant read any of the words, I cant see what any of the settings are in game. My native resolution is 1280x1024. Heres a link with what the game looks like.

http://img52.imageshack.us/i/mw2distortion.jpg/
m
0
l
Related resources
a b U Graphics card
December 5, 2009 4:10:38 PM

OK, that's odd. I was thinking perhaps the fonts were being rendered too small or something but this is a full on graphical defect.

Any other games ever have this problem? What PSU do you have?
m
0
l
December 5, 2009 4:37:37 PM

Updating the drivers won't do anything. ATi phased out anything less the the HD2XXX series close to the beginning of the year
m
0
l
December 5, 2009 9:48:54 PM

The strange thing to me is that I can play the game fine, kill people and explosions all are looking great. Oh also, when an explosion goes off near me, shrapnel or something would come on my screen but it is also really messed up looking. Green, purple, gray, yellow, lines up and down my screen and they fade out when I've recovered from the blast. I get no lag at all even with my below spec CPU. My Specs are:

Every other game I have work great. CoD4 runs full graphics well.

CPU: Intel P4 2.8ghz
GPU: ATI Radeon X1950
Power Supply: 520W
RAM: 2.25Gb

Thanks!
m
0
l
January 14, 2010 11:03:40 AM

hi bjohnston29 have you managed to fix the problem? as im having the same problem
m
0
l
a c 189 U Graphics card
January 14, 2010 12:06:33 PM

maybe u want to check the card's temps to see if your card is overheating or not...
Did u try to re-install the game?
m
0
l
February 12, 2010 8:20:22 PM

WAHHHH I HAVE RADEON X2300 AND I CANT GET RID OF DAH SAME PROBLEM. how annoying is it when explosions go of near u.

PLEASE PLEASE JOHNSON IF YOU FIND ANSWER EMAIL AT matrixdan1995@hotmail.com
m
0
l
a c 173 U Graphics card
February 12, 2010 9:48:07 PM

Sounds like you got an artifacting problem and I suggest cleaning the cooler as well replacing the 3 year old compound. Turn the fan speed up as well. I my self on my x1900xt have the fan speed set to 62-72% which the card idels around 42-55c. Load is 65c at the most unless there is a heat wave.
m
0
l
February 18, 2010 9:42:44 AM

uhh im on a laptop
m
0
l
a c 173 U Graphics card
February 18, 2010 12:38:47 PM

matrixdan said:
uhh im on a laptop


Then your screwed...... Get a can of compressed air and blast around the vents on the side or back of your laptop to remove and dust that may be clogging the coolers inside.
m
0
l
!