Sign in with
Sign up | Sign in
Your question

My RAID failed, now what?

Tags:
Last response: in Storage
Share
November 4, 2011 10:23:44 PM

Please give this thread a quick read to get the background:

http://www.tomshardware.com/forum/forum2.php?config=tom...

Basically I just setup a RAID1 configuration with 2 1.5TB WD drives in an external enclosure connected via eSATA to my main PC. Once they synched everything appeared to be fine and I was able to access the disk and was feeling quite proud of myself. I ran into a secondary issue however where the external enclosure kept powering off and then not waking up when the PC came out of hibernation so I've been playing with some of the power management settings trying to resolve this (specifically I set the 'Turn Off Hard Disk' option to 'Never' and the 'Link State Power Management' under PCIExpress to Off (my eSATA connection is a card on the PC)). So far this didn't fix the problem but that's another matter entirely, onto the immediate issue:

Today I was messing with some cabling behind the PC and I inadvertently knocked out the AC power plug and turned the machine off. When I rebooted my mirrored RAID array did not come up so I went into Disk Management to investigate. It showed my mirrored drives as 2 seperate entries in a 'Failed' state. It also showed a 3rd drive that it listed as 'foreign'. So after a little googling I tried reactivating the failed mirrored drive. First I gotta popup that said 'The Plex is missing' and then both drives updated with the status 'Failed Redundancy'. Some more googling and I followed this article: http://buildegg.com/bewp/?p=44 and removed the failed mirror. The drive then converted back to a simple volume that was accessible as normal with the files intact and the mirrored volume of course was removed. Next I clicked on the 'foreign' disk and selected 'Import Foreign Disk' and lo and behold it restored the 2nd disk. So now I have 2 simple volumes with the same data but no RAID1.

Anyone have any clue what the hell is going on here and how I resolve this?

thanks so much for your help

More about : raid failed

a c 328 G Storage
November 7, 2011 2:38:57 AM

I do not use Windows' version of RAID1, but I do use a RAID1 system built into the mobo of a machine in our retail store. In that system if one of the two members of the RAID1 array experiences a problem, the software in the BIOS that runs it has a procedure to Repair the array. Basically it has to recopy all the stuff from the good drive back to the corrupted drive. Now, IF it can identify only a limited number of corrupted files, it may be able to fix them only in a reasonable time. A major problem may really come down to a second option you can always do manually.

Right now you have two drives with nearly identical info on them, and Drive 1 is known to be good and complete. In essence, what has been accomplished already is that you have "broken" the RAID1 array into two independent drives with data. Unless the Windows RAID management system includes some Repair options, you can fix it manually. This assumes that, in fact, Drive 2 does not have any real hardware problem - the whole issue was caused solely by data corruption when the power was disrupted.

You can do what you did to establish your RAID1 array in the first place. Delete the Partition on Drive 2. Then use the Add Mirror option on Drive 1 to create the RAID1 array from one good drive with data (Drive 1) and one empty good drive (Drive 2).
November 7, 2011 7:28:43 PM

leandrodafontoura said:
Friend, you should use hardware raid over software raid. It may be not as versatile, but its more reliable. If I were you, I would start from scratch. I assume you have backups. If you dont, WD makes excelent external drives, including esta mirrored external drives, but my favorite backup is the my passport

http://www.amazon.com/Western-Digital-Passport-Essentia...

http://www.amazon.com/Western-Digital-My-Book-Studio/dp...


OK so I should buy a RAID controller card and set it up that way?
Do you have a card you can recommend?
!