Hard Drive Displaying as BD-Rom

Hi, I was about to throw away my old PC today and looked inside to see what I could salvage. I noticed that the hard drive was 90gb and figured id stick it into one of my new PC's..

after looking inside one i found that there already a power cable, and a slot for the (IDE?)cable. looked at the back of the drive and there are pictures for how little blocks should be to select how the drive should act or whatever.. its set to cable select, I figured Id just stick it in and see what happened..

pc boot into windows from my origional HD as normal, and came up with the windows is installing drivers etc.. once its installed it comes up as BD-ROM Drive (E:) which looking around is something to do with blueray..

tried unistalling the drivers and rebooting but get the same DTSoftBusCd00 driver installed...

Not quite sure what to do... my old PC had Ubuntu installed on it.. not sure if this is an issue having a differant file system or whatever but I dont get the option to format it

Any ideas?
1 answer Last reply
More about hard drive displaying
  1. Also, just changed jumpers to "slave" but the same result...

    Extra info

    From the Bios/CMOS Setup Utility

    >> standard CMOS Features
    Says

    Primary IDE Master : Hard Disk
    Primary IDE Slave : Not Detected
    Secondary IDE Master : ATApi cdrom
    Secondary IDE Slave : Not Detected
    Third IDE Master : Not Detected
    Third IDE Slave : Hard Disk

    >> Advanced Bios Features >> Hard Disk Drives

    1st Drive : Hitachi HDT7250025VL
    2nd Drive : HDS728080PLAT20 (The Drive I'm trying to get to work)
    3rd Drive : Generic USB MS Read
Ask a new question

Read More

Hard Drives Cable Storage