Sign in with
Sign up | Sign in
Your question
Closed

One busy CPU makes task-switching crawl

Last response: in Windows XP
Share
June 13, 2012 1:45:52 PM

I have noticed this in the past, but it is massive on my new work machine. Although the machine has four processors, when one is working full-out it takes forever to get the machine's attention.

It's an HP Elitebook 8560w, with 4 cores running at - whoops, it's idle now and they are throttled down to 798 Mhz. Rated at 2 Ghz. 8 GB of dual-channelDDR3 at 666 Mhz, FSB:RAM ratio of 1:5. Running 32-bit XP until the company certifies 64-bit Win7 for use.

When I run a massive single-thread computation, like recompiling our main project and running all of the Junit tests, I see one CPU running flat-out and the others nearly idle. But if I try to switch tasks, or hit ctl-alt-delete and open the task manager, it can take up to ten seconds to get its attention. Is this a normal behavior for XP? Can you think of any reason? There is a lot of company security stuff running in the background, but it's usually quiet, and I never have this problem unless one core is being pushed full-out.

If it makes a difference, I disabled Hyperthreading. I haven't yet tried the experiment of re-enabling it.

Thanks.
June 13, 2012 2:50:07 PM

HP is kind of a "pretend" fast machine.
It does not really have fast components.
666 RAM is pathetically slow.
BUT there is "cool and quiet" or "cool mode"set in the bios, that slows the machine down quite a bit. This makes the CPU idle, you don't want that.
you can turn that cool and quiet OFF in the bios settings, usually.
Open the windows 7 power profile and set to: "performance mode"
Set the hard drive to: "always running"
The HP has pretty inadequate cooling, but you can install an aftermarket cooler like "coolermaster." Maybe get some case fans installed...
Then, it helps quite a bit to use 2 hard drives.
Use a small fast drive just for the operating system and applications. Use about 70GB drive. Velociraptor is good...
ONE hard drive is just for the operating system and applications, set this drive to boot FIRST.
The other drive is for your files only. Keep the files OFF the operating system drive.
Use the LARGE drive for the files only.
Do not put the OS on a large drive.
The larger the drive, the slower it will go. If you have a 1-2 TB drive, NO WONDER it crawls. Using ONE drive for everything, instead of TWO, it will go even slower.
Loading updates will make it slow, the more updates you load, the slower it will run.
Last, security. Use an all in one professional security system. DO NOT use free security downloaded from the internet.
Do not use multiple security programs, they conflict.
Hyperthread should be enabled.

When you buy a new computer, it comes "loaded" with junk software. Erase ALL the junk programs, especially "HP features"
HP apps drown the hard drive in totally unnecessary "features," POP UP HP advertising, etc...get rid of all the junk applications on the drive.
Score
0
June 14, 2012 1:19:56 PM

soundguruman

That's going to take me a while to assimilate and respond to!

It being a work machine, I can't do things like install two drives or cooling, control updates, or control the security software. I will look at the other things. But it's not a question of being "fast" - the stuff doesn't run much better under a 32-bit OS on my home machine. It flies under Win7 with 8 GB, but as I said they are not through validating that for work.

The problem is the task switching. With three idle CPUs, I can't get the -blessed- thing's attention. Given how much difference memory seems to make, maybe the problem is that it has to page out to make room for the next task? My commit charge gets fairly large when this is happening, 3 GB or more.

I will try some of the other suggestions and see if they work. Thanks for sharing your experience with me.
Score
0
!