The Disk is write-protected. Remove the write-protection

I just bought an 8 gb Kingston data traveler 101 usb. After successfully transferred around 650 mb of files, the rest did not copied to the flash disk. It said:

"The disk is write-protected. Remove the write-protection or use another disk."

I tried to remove the copied files or format the flash disk but to no avail. The same message was flashed to the screen.

Could you help me how to remove this write-protection from my usb Kingston data traveler 101?

Thank you.
3 answers Last reply
More about disk write protected remove write protection
  1. Read this pretty good and helpful article:

    Follow the steps

    How to remove a write protection from your USB memory Stick if there is no Write protection ON or OFF button on stick then
    1. Shutdown your computer or laptop
    2. Insert USB Memory Stick into your laptop or Computer
    3. Turn on laptop and then immediately start pressing (F8) key then Advanced Boot Options screen will come up
    4. Select Safe Mode with Command Prompt
    5. After loading files if your USB Memory Stick drive letter is (G) for example then write as
    6. C:\windows\system32>G: and press enter
    7. G:\>format G: and press enter
    8. If ask you (Y/N) then press (Y) and press enter
    9. Now a full format will start which remove write protection from USB Memory Stick.
    Before removing USB from your computer, Always remove it safely by going into to my computer then right click on USB and click eject.
  2. cannot work this way to format my kingston usb..
  3. i have read many different solutions but none really of them even so-jested rewriting my memory card.
    the quick and easy thing to do is remove the memory card from the computer then put it back and eject the card the correct way. after u are ready to transfer files.:bounce:
Ask a new question

Read More

Flash Media Kingston Data Traveler USB Write Protection Storage