Sign in with
Sign up | Sign in
Your question

Memtest86+ : ERRORs only at test #6 & only if 4 DIMMs are set

Tags:
Last response: in Memory
Share
Anonymous
a b } Memory
June 20, 2010 8:10:47 AM

Hi :) 

I have a problem, and I'd need to find some help because I don't know what to do ... and there's job waiting to be done :( 
Please, I need help with this.

My system :

Asus P5k-E/WiFi AP (Intel P35 chipset)
Intel COre 2 Q6600
G.Skill F2-6400CL5-2GBPQ (4 modules, 2gb each for a 8gb total) working in dual channel.
nVidia GTS-250 1024Mb
3x WD Caviar 500Gb HDD, 2 of them working in RAID1 configuration.
Memory card reader, DVD Burner, etc ...
Windows Vista Ultimate x64 SP1

No overcloking, everything memory and CPU related set at Auto. Intel Speed step decides when to boost the CPU.


This is my problem.

I've been running this system without a problem for the last year, and before that I was using just 2 G.Skill DIMMs for a 4Gb total. I added the two new modules a year ago and everything was working perfectly since then.

A couple days ago things went wrong. The PC started hanging at random (or so it seems to me) and I've tried to pinpoint what the problem might be.

I decided to start testing the memory as any windows test I did was helping to pinpoint the problem.

I first tried some old memtest86 I had, v2.10 I guess, but the progran locked up ... supposedly when it found errors, i don't know. So, I downloaded the latest memtest86+ avalable, 4.10, burned a DVD and started testing. I also disabled USB legacy as i read it might be cause of truble.

These are my findings and the reason I'm completely at a loss :


I tested one module on the 4 different memory slots for 4-5 passes ... so 20 passes in total. No error.
I tested each individual module for 4-5 passes on the same bank. No problem at all, no error

I tested each couple of "dual channel" DIMMs. 5 hours straight each, no error.

I tested all 4 DIMMs. Errors everywhere when the process reached test #6 (moving inversions, 32 bit pattern).
I've repeated the wholes test run a few times. It always start throwing errors when it reaches test #6. No other tests causes a problem that I know of.

I've a set the program to just perform test #6. Sometimes it needs 2 passes to start failing, but most times it starts in the 1st pass.
Sometimes the errors start at 2048M - 3328M, 16% complete ... or at 8192 - 8960, 15% ... or at 188K - 2048M, 6% ... no consistency at all.


So, in short ... it only fails the test #6 ... and only when the 4 modules are set.


Another bit o info that I've observed.

DMI memory device info (hitting 'c', then '5') shows normal info until the errors start. Then it shows corrupted text (IE, things like ... DIMt3 instead of DIMM3, empty spaces instead of DIMM0, one module shows speed 65056 instead of 800, mapped to: no mapping on DIMM 0 ... all the info looks weird, corrupted. ). But the program continues to perform apparently OK, though I usually can't get out of test #6 or reboot pressing ESC.

On the main screen, CAS : 5-5-5-15 shows correct info, until the errors start appearing, then sometimes shows nonsense values like 45-64-37-1.


So ... what's your oppinion ? Any test that can help ? Any info you need me to provide ? What could be causing this situation ? Please, I need help.
Anonymous
a b } Memory
June 20, 2010 12:45:25 PM

Yes, 1.85 and 1.9.
And upping the north bridge voltage to 1.4 too.

No luck.


But one thing worked ... relaxing the timings from 5-5-5-15 to 6-6-6-16. Or it's working so far, don't know if it will last.

But ... I'm trying to find wich part is the one that went wrong.
June 21, 2010 10:25:32 AM

The main things to stabilise 4 strips are going to be Ram Volts, N/B Volts, RAM Speed and Timings. If you are able to run each pair in Dual channel mode without errors they there isn't likely a part which is 'going wrong'. It is likely you have found a chipset limitation, that your P35 board is having trouble with 4 strips at certain speeds/latencies, especially as you have found relaxing the timings has helped the stability.

My bro used to have an Abit IP35 motherboard and 4x 1Gb Corsair Dominator 1066Mhz 5-5-5-15 RAM. We tried everything we could to stabilise them at 1066Mhz with N/b volts up to 1.6v but in the end the chipset just couldn't handle 4 strips at that speed. He ended up running them at 850Mhz 4-4-4-12 with a small bump on the northbridge voltage.

To find out if this is the case with your board I would try setting all the RAM specs manually - 800Mhz, 1.9v, 5-5-5-15, then up your n/b volts incrementally up to around 1.5v max and see if you can stabilise it. If not, you know your n/b can't hack it at those speeds/latencies no-matter what the voltage. Then you can start either relaxing timings or reducing the frequency of the RAM and trying the N/B voltages again to see if you can stabilise it. Eventually you should arrive somewhere where it stabilises.
a c 97 } Memory
June 21, 2010 2:42:59 PM

Quote:
Yes, 1.85 and 1.9.
And upping the north bridge voltage to 1.4 too.

No luck.


But one thing worked ... relaxing the timings from 5-5-5-15 to 6-6-6-16. Or it's working so far, don't know if it will last.

But ... I'm trying to find wich part is the one that went wrong.


4 sticks will normally need more ram voltage than 2. It is strange that a previously working system should start to show signs of instability. It indicates to me that some component is gradually weakening, either the motherboard or ram. Probably the motherboard. Since you seem to be able to control the problem by losening the timings, then just stick with it, or even loosen them more. The higher timings or slower speed will not show up as a significant difference in real application performance.
!