Sign in with
Sign up | Sign in
Your question

XP pro and Apache 2

Last response: in Windows XP
Share
Anonymous
September 16, 2004 8:08:00 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

Hi!

I have setup Apache2 on my XP Pro system. I am trying to setup the Apache
in a virtualhost mode to run Perl *cgi and *pl scripts. When I try access
localhost from my broswer I get the following:

I have ask the Apache group for help and get the following:

The page cannot be displayed
The page you are looking for is currently unavailable. The Web site
might be experiencing technical difficulties, or you may need to adjust your
browser settings.

--------------------------------------------------------------------------

Please try the following:

a.. Click the Refresh button, or try again later.

b.. If you typed the page address in the Address bar, make sure that
it is spelled correctly.

c.. To check your connection settings, click the Tools menu, and
then click Internet Options. On the Connections tab, click Settings. The
settings should match those provided by your local area network (LAN)
administrator or Internet service provider (ISP).
d.. See if your Internet connection settings are being detected. You
can set Microsoft Windows to examine your network and automatically discover
network connection settings (if your network administrator has enabled this
setting).
1.. Click the Tools menu, and then click Internet Options.
2.. On the Connections tab, click LAN Settings.
3.. Select Automatically detect settings, and then click OK.
e.. Some sites require 128-bit connection security. Click the Help
menu and then click About Internet Explorer to determine what strength
security you have installed.
f.. If you are trying to reach a secure site, make sure your
Security settings can support it. Click the Tools menu, and then click
Internet Options. On the Advanced tab, scroll to the Security section and
check settings for SSL 2.0, SSL 3.0, TLS 1.0, PCT 1.0.
g.. Click the Back button to try another link.



Cannot find server or DNS Error
Internet Explorer


I think so. But I'm no Win expert. So you'd better ask in a microsoft
related newsgroup or start googling with "how do I force hostname resolution
without a dns in windows".

I have made the changes:

# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost
127.0.0.1 jwp

Any ideas?

Thanks,

Jerry

More about : pro apache

September 17, 2004 7:00:31 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

how did you save the HOSTS file in system32\drivers\etc?
it doesn't by any chance have a file extention of .txt, because if it does
it will not be recorgnized as being the HOSTS (no extension) file.
not an uncommon mistake.

your apache service is responding to requests coming in on port 80?

other than that I wouldn't know at this point

georde


"Gerald Preston" <jwp@ont.com> wrote in message
news:10kilvjqrh8fg7b@corp.supernews.com...
> Hi!
>
> I have setup Apache2 on my XP Pro system. I am trying to setup the Apache
> in a virtualhost mode to run Perl *cgi and *pl scripts. When I try access
> localhost from my broswer I get the following:
>
> I have ask the Apache group for help and get the following:
>
> The page cannot be displayed
> The page you are looking for is currently unavailable. The Web site
> might be experiencing technical difficulties, or you may need to adjust
> your browser settings.
>
> --------------------------------------------------------------------------
>
> Please try the following:
>
> a.. Click the Refresh button, or try again later.
>
> b.. If you typed the page address in the Address bar, make sure
> that it is spelled correctly.
>
> c.. To check your connection settings, click the Tools menu, and
> then click Internet Options. On the Connections tab, click Settings. The
> settings should match those provided by your local area network (LAN)
> administrator or Internet service provider (ISP).
> d.. See if your Internet connection settings are being detected.
> You can set Microsoft Windows to examine your network and automatically
> discover network connection settings (if your network administrator has
> enabled this setting).
> 1.. Click the Tools menu, and then click Internet Options.
> 2.. On the Connections tab, click LAN Settings.
> 3.. Select Automatically detect settings, and then click OK.
> e.. Some sites require 128-bit connection security. Click the Help
> menu and then click About Internet Explorer to determine what strength
> security you have installed.
> f.. If you are trying to reach a secure site, make sure your
> Security settings can support it. Click the Tools menu, and then click
> Internet Options. On the Advanced tab, scroll to the Security section and
> check settings for SSL 2.0, SSL 3.0, TLS 1.0, PCT 1.0.
> g.. Click the Back button to try another link.
>
>
>
> Cannot find server or DNS Error
> Internet Explorer
>
>
> I think so. But I'm no Win expert. So you'd better ask in a microsoft
> related newsgroup or start googling with "how do I force hostname
> resolution
> without a dns in windows".
>
> I have made the changes:
>
> # Copyright (c) 1993-1999 Microsoft Corp.
> #
> # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
> #
> # This file contains the mappings of IP addresses to host names. Each
> # entry should be kept on an individual line. The IP address should
> # be placed in the first column followed by the corresponding host name.
> # The IP address and the host name should be separated by at least one
> # space.
> #
> # Additionally, comments (such as these) may be inserted on individual
> # lines or following the machine name denoted by a '#' symbol.
> #
> # For example:
> #
> # 102.54.94.97 rhino.acme.com # source server
> # 38.25.63.10 x.acme.com # x client host
>
> 127.0.0.1 localhost
> 127.0.0.1 jwp
>
> Any ideas?
>
> Thanks,
>
> Jerry
>
Anonymous
September 18, 2004 10:56:32 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

George,

No txt extension. I can ping the host www.gjwpp.com that I set up.

I am currently getting the following:

The requested URL could not be retrieved

--------------------------------------------------------------------------------

While trying to retrieve the URL: http://www.gjwpp.com/

The following error was encountered:

Unable to determine IP address from host name for www.gjwpp.com
The dnsserver returned:

Name Error: The domain name does not exist.
This means that:

The cache was not able to resolve the hostname presented in the URL.
Check if the address is correct.
Your cache administrator is root.


Thanks,

Jerry


"george" <anonymous@discussions.microsoft.com> wrote in message
news:uWPeKIFnEHA.3896@TK2MSFTNGP15.phx.gbl...
> how did you save the HOSTS file in system32\drivers\etc?
> it doesn't by any chance have a file extention of .txt, because if it does
> it will not be recorgnized as being the HOSTS (no extension) file.
> not an uncommon mistake.
>
> your apache service is responding to requests coming in on port 80?
>
> other than that I wouldn't know at this point
>
> georde
>
>
> "Gerald Preston" <jwp@ont.com> wrote in message
> news:10kilvjqrh8fg7b@corp.supernews.com...
>> Hi!
>>
>> I have setup Apache2 on my XP Pro system. I am trying to setup the
>> Apache in a virtualhost mode to run Perl *cgi and *pl scripts. When I
>> try access localhost from my broswer I get the following:
>>
>> I have ask the Apache group for help and get the following:
>>
>> The page cannot be displayed
>> The page you are looking for is currently unavailable. The Web site
>> might be experiencing technical difficulties, or you may need to adjust
>> your browser settings.
>>
>> --------------------------------------------------------------------------
>>
>> Please try the following:
>>
>> a.. Click the Refresh button, or try again later.
>>
>> b.. If you typed the page address in the Address bar, make sure
>> that it is spelled correctly.
>>
>> c.. To check your connection settings, click the Tools menu, and
>> then click Internet Options. On the Connections tab, click Settings. The
>> settings should match those provided by your local area network (LAN)
>> administrator or Internet service provider (ISP).
>> d.. See if your Internet connection settings are being detected.
>> You can set Microsoft Windows to examine your network and automatically
>> discover network connection settings (if your network administrator has
>> enabled this setting).
>> 1.. Click the Tools menu, and then click Internet Options.
>> 2.. On the Connections tab, click LAN Settings.
>> 3.. Select Automatically detect settings, and then click OK.
>> e.. Some sites require 128-bit connection security. Click the Help
>> menu and then click About Internet Explorer to determine what strength
>> security you have installed.
>> f.. If you are trying to reach a secure site, make sure your
>> Security settings can support it. Click the Tools menu, and then click
>> Internet Options. On the Advanced tab, scroll to the Security section and
>> check settings for SSL 2.0, SSL 3.0, TLS 1.0, PCT 1.0.
>> g.. Click the Back button to try another link.
>>
>>
>>
>> Cannot find server or DNS Error
>> Internet Explorer
>>
>>
>> I think so. But I'm no Win expert. So you'd better ask in a microsoft
>> related newsgroup or start googling with "how do I force hostname
>> resolution
>> without a dns in windows".
>>
>> I have made the changes:
>>
>> # Copyright (c) 1993-1999 Microsoft Corp.
>> #
>> # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
>> #
>> # This file contains the mappings of IP addresses to host names. Each
>> # entry should be kept on an individual line. The IP address should
>> # be placed in the first column followed by the corresponding host name.
>> # The IP address and the host name should be separated by at least one
>> # space.
>> #
>> # Additionally, comments (such as these) may be inserted on individual
>> # lines or following the machine name denoted by a '#' symbol.
>> #
>> # For example:
>> #
>> # 102.54.94.97 rhino.acme.com # source server
>> # 38.25.63.10 x.acme.com # x client host
>>
>> 127.0.0.1 localhost
>> 127.0.0.1 jwp
>>
>> Any ideas?
>>
>> Thanks,
>>
>> Jerry
>>
>
>
September 19, 2004 3:47:55 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

OK. I'm not into Apache, but from what I gather so far, you've got it
running on your XP box as a 'virtual webserver' and from that box you can
ping the hostname www.gjwpp.com.
Am I correct so far? (Hope so)
However, using a web browser you cannot get the page, because of
The page cannot be displayed
Cannot find server or DNS Error

This indicates that the browser is consulting a DNS server (through your
TCP/IP configuration settings) or maybe none at all and that DNS server
cannot resolve www.gjwpp.com into an IP address.
Where is your TCP/IP config DNS server address pointing to and does that
server have an address for your 'virtual apache webserver'?
Probably not, unless you have some DNS service running somwhere.

The only option left open for your XP web browser request to get to your
webserver is the HOSTS file and in that file I see no reference to
www.gjwpp.com (provided the info you gave earlier on the contents of the
file is complete).
So add 127.0.0.1 www.gjwpp.com to that file.

hope I'm not waaayyy of the mark with my assumptions here.

george


"Gerald Preston" <jwp@ont.com> wrote in message
news:10ko8jhncpudh2c@corp.supernews.com...
> George,
>
> No txt extension. I can ping the host www.gjwpp.com that I set up.
>
> I am currently getting the following:
>
> The requested URL could not be retrieved
>
> --------------------------------------------------------------------------------
>
> While trying to retrieve the URL: http://www.gjwpp.com/
>
> The following error was encountered:
>
> Unable to determine IP address from host name for www.gjwpp.com
> The dnsserver returned:
>
> Name Error: The domain name does not exist.
> This means that:
>
> The cache was not able to resolve the hostname presented in the URL.
> Check if the address is correct.
> Your cache administrator is root.
>
>
> Thanks,
>
> Jerry
>
>
> "george" <anonymous@discussions.microsoft.com> wrote in message
> news:uWPeKIFnEHA.3896@TK2MSFTNGP15.phx.gbl...
>> how did you save the HOSTS file in system32\drivers\etc?
>> it doesn't by any chance have a file extention of .txt, because if it
>> does it will not be recorgnized as being the HOSTS (no extension) file.
>> not an uncommon mistake.
>>
>> your apache service is responding to requests coming in on port 80?
>>
>> other than that I wouldn't know at this point
>>
>> georde
>>
>>
>> "Gerald Preston" <jwp@ont.com> wrote in message
>> news:10kilvjqrh8fg7b@corp.supernews.com...
>>> Hi!
>>>
>>> I have setup Apache2 on my XP Pro system. I am trying to setup the
>>> Apache in a virtualhost mode to run Perl *cgi and *pl scripts. When I
>>> try access localhost from my broswer I get the following:
>>>
>>> I have ask the Apache group for help and get the following:
>>>
>>> The page cannot be displayed
>>> The page you are looking for is currently unavailable. The Web site
>>> might be experiencing technical difficulties, or you may need to adjust
>>> your browser settings.
>>>
>>> --------------------------------------------------------------------------
>>>
>>> Please try the following:
>>>
>>> a.. Click the Refresh button, or try again later.
>>>
>>> b.. If you typed the page address in the Address bar, make sure
>>> that it is spelled correctly.
>>>
>>> c.. To check your connection settings, click the Tools menu, and
>>> then click Internet Options. On the Connections tab, click Settings. The
>>> settings should match those provided by your local area network (LAN)
>>> administrator or Internet service provider (ISP).
>>> d.. See if your Internet connection settings are being detected.
>>> You can set Microsoft Windows to examine your network and automatically
>>> discover network connection settings (if your network administrator has
>>> enabled this setting).
>>> 1.. Click the Tools menu, and then click Internet Options.
>>> 2.. On the Connections tab, click LAN Settings.
>>> 3.. Select Automatically detect settings, and then click OK.
>>> e.. Some sites require 128-bit connection security. Click the
>>> Help menu and then click About Internet Explorer to determine what
>>> strength security you have installed.
>>> f.. If you are trying to reach a secure site, make sure your
>>> Security settings can support it. Click the Tools menu, and then click
>>> Internet Options. On the Advanced tab, scroll to the Security section
>>> and check settings for SSL 2.0, SSL 3.0, TLS 1.0, PCT 1.0.
>>> g.. Click the Back button to try another link.
>>>
>>>
>>>
>>> Cannot find server or DNS Error
>>> Internet Explorer
>>>
>>>
>>> I think so. But I'm no Win expert. So you'd better ask in a microsoft
>>> related newsgroup or start googling with "how do I force hostname
>>> resolution
>>> without a dns in windows".
>>>
>>> I have made the changes:
>>>
>>> # Copyright (c) 1993-1999 Microsoft Corp.
>>> #
>>> # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
>>> #
>>> # This file contains the mappings of IP addresses to host names. Each
>>> # entry should be kept on an individual line. The IP address should
>>> # be placed in the first column followed by the corresponding host name.
>>> # The IP address and the host name should be separated by at least one
>>> # space.
>>> #
>>> # Additionally, comments (such as these) may be inserted on individual
>>> # lines or following the machine name denoted by a '#' symbol.
>>> #
>>> # For example:
>>> #
>>> # 102.54.94.97 rhino.acme.com # source server
>>> # 38.25.63.10 x.acme.com # x client host
>>>
>>> 127.0.0.1 localhost
>>> 127.0.0.1 jwp
>>>
>>> Any ideas?
>>>
>>> Thanks,
>>>
>>> Jerry
>>>
>>
>>
>
>
!