Sign in with
Sign up | Sign in
Your question
Solved

New GA 890GPA-UD3H Two Problems

Last response: in Motherboards
Share
June 21, 2010 9:45:08 PM

This board has only one PS2 port. Coupled with that limitation, a USB mouse connected to a USB port is not loaded in DOS.

I need both in order to run Drive Image 2002.

I've tried a PS2 Y cable, but the board only recognizes one of the devices in DOS. To get both a mouse and keyboard working for Drive Image 2002 (in Caldera DOS), I have to connect the mouse to the PS2 port, boot to the first floppy. It loads the mouse driver, and says press any key to continue. The keyboard isn't working in USB so I disconnect the mouse to the PS2 port, connect the keyboard, hit any key, and it continues. Then I have to disconnect the keyboard and connect the mouse again to PS2, because only the mouse is required for DI 2002.

The second problem shows up on every boot. The screen is black until it gets to "loading operating system". No splash screen of any kind, whether disabled or enabled. But, I can use the pause key to slow down the boot, then the splash screen may appear.

I think I'd like a better mobo.

More about : 890gpa ud3h problems

a c 177 V Motherboard
June 21, 2010 11:03:09 PM

Enter BIOS - <DEL> key at POST or 'flash' screen...

Go to "Integrated Peripherals" page, on "USB Device Setting" sub-page, set "USB Legacy Function" to "Enabled" - peculiar though - should be 'defaulted' to "Enabled" to begin with - also peculiar: on every other board I am aware of (will take a peek at a few other 890-based boards for aomparison - maybe an AMD thing?), function is directly on the "Integrated Peripherals" page, and is named "USB Keyboard Support" - hope they haven't managed to 'ditz up' something they've had working for years! I had always wondered what was up with this setting, as, to my 'idle eye', it seemed every GB board I ever used would allow a USB kbd in the BIOS no matter which way the setting was configured - answering questios here 'showed' me the actual idea - USB is 'covered' by the BIOS own 'version' of a 'driver', but once you leave the BIOS, but before you've loaded an OS that has its own USB drivers, you're left 'high and dry' without this setting enabled! For some boards, this is even a problem with the 'press any key to boot from CD' message - USB kbd not enabled in BIOS, never 'sees' that <ANY> key! Some utilities fail at 'seeing' the keys, even with the setting correctly enabled - one that comes to mind is the 'boot time defrag' util in Diskeeper (maybe call int09h functions instead of int16h??)

As for 'black screen thing, what OS are you loading? New build, I assume?
m
0
l
a c 177 V Motherboard
June 21, 2010 11:27:02 PM

Acckk! I just finally 'comprehended' your problem - nevermind the above! (In my defense, I'm an old fart [:bilbat:6] and my mind 'wanders' [:bilbat:2])

Uploaded something to MediaFire for you to try: http://www.mediafire.com/?wljozmnhwmw
...just add one or the other file to your boot disk, and your autoexec... tell me if it works, might be able to find some others [:isamuelson:8]

BTW - love your 'handle'; sounds like a 'Clue' thing - Colonel Debugger in the Protected Mode room, with the 'trace axe'! [:bilbat:9] [:jaydeejohn:4]
m
0
l
Related resources
June 22, 2010 1:07:33 AM

That's exactly what I need. But, when I copied OCHI to the floppy, and added a:\ohci.exe to the autoexe.bat and boot to that floppy it says
USB Link USB stack driver ver 2.5 OHCI USB controller initialized. Then,
unfortunately, the loading stops, it does not continue to load the rest of autoexec.bat.

I must be putting it in the wrong place in autoexebat. I've never edited autoexecbat, but found out with Edit that I can write there:

Here's the autoexecbat on the DriveImage first floppy:


@ECHO OFF
PROMPT $P$G


REM -------------------------------------------------------
REM -- Put keyboard codes (xx) and --
REM -- code page variables (yyy) here. --
REM -------------------------------------------------------

REM MODE CON CP PREP=((yyy) EGA.CPI)
REM MODE CON CP SEL=yyy
REM KEYB xx,yyy


REM -------------------------------------------------------
REM -- Put network or CD-ROM drivers here. --
REM -------------------------------------------------------

REM Windows DOS:
REM MSCDEX.EXE /D:D river_name [/L:D rive_letter] [/M:buffers]

REM Caldera DOS:
REM NWCDEX.EXE /D:D river_name [/L:D rive_letter] [/M:buffers]

MOUSE

SET TZ=PST8PDT7,M3.2.0,M11.1.0

ECHO.
ECHO Insert Drive Image Disk 2 (Program)
ECHO.
ECHO.
ECHO *** Press Any Key to Continue ***
ECHO.
PAUSE >NUL


ECHO Drive Image 2002
ECHO Copyright 1994-2002, PowerQuest Corporation.

PS I'm using Win XP Pro.
m
0
l
a c 177 V Motherboard
June 22, 2010 1:21:27 AM

Tell 'ya what - I'm in the middle of doing dishes here - when I get done, I think I've got a DOS boot disk floating around here somewhere, I'll try 'em both, and give a holler back...
m
0
l
June 22, 2010 1:47:08 AM

I'd appreciate that. By the way, when I load that floppy, it says Mouse not detected, mouse driver not loaded. I suppose that's because the mouse is on USB and is therefore not detected.

PS The kernel part does represent Colonel. Retired fighter pilot.
m
0
l
a c 177 V Motherboard
June 22, 2010 2:50:19 AM

Gotta do a couple things... I got UNCI to load successfully, but I gotta find something to test it with, and see if it's actually 'seeing' the mouse. Second, could you capture and post a directory of that first disk? I'd like to look at the file sizes to try to figure out what DOS it's loading... Or, you could insert:
Quote:
REM Caldera DOS:
REM NWCDEX.EXE /D:D river_name [/L:D rive_letter] [/M:buffers]

MOUSE
VER
SET TZ=PST8PDT7,M3.2.0,M11.1.0

ECHO.
ECHO Insert Drive Image Disk 2 (Program)

which should cause it to 'show' you a version number...


Quote:
Retired fighter pilot.

Exquisite! Love(d) flying - no license due to psych meds :fou:  In my youth (wayyy back when [:bilbat:6] ), had an appointment to Naval Academy - was fifteen, would have graduated HS at sixteen (smart, but manic-depressive, turned out...), had my @$$ beat nearly every day in HS by the 'football crowd', was too scared of the prospects of 'hazing' to go :cry:  later read about the 'order of the wet britches', or whatever, for people who pi$$ed themselves making that first night carrier landing - thought "dammit, I should've done that!" Dunno if they'da let me, though, am fairly large - 6'1", don't know whether that was permissible back in, say, seventy-four or five... Think it was F-14's & 15's back then?
m
0
l
a c 177 V Motherboard
June 22, 2010 2:53:48 AM

Oh - and may be 'all she wrote' for tonight - tornado warnings here - thinking it mightn't be a bad idea to shut down for the night - even if I knew where the H my UPS was, a sytem like this is good for about two minutes on batteries!
m
0
l
June 22, 2010 4:32:41 AM

A:/DIR

MOUSE INI 24
AUTOEXEC BAT 1046
CHKDSK EXE 59,471
CONFIG SYS 526
DISPLAY SYS 3,877
EGA CPI 24,888
FDISK COM 22,827
HIMEM SYS 14,877
KEYB COM 12,187
MODE COM 16,025
MOUSE COM 37,681
NWCDEX EXE 21,756
PARTINFO EXE 189,996

It sez it loads mouse driver version 8.20

Drive Image 2002 comes on a CD. It makes two floppy disks that
run the program in Caldera DOS.

We can terminate this endeavor whenever you wish. I need to
do more research on enabling USB in DOS.
m
0
l
June 22, 2010 4:42:53 AM

When the first floppy is loading, it shows:

Caldera Dos Version 7.03

HTH
m
0
l
a c 177 V Motherboard
June 22, 2010 7:57:37 AM

Ahh - Caldera DOS... Think I saw something when searching, probably why the two files I posted don't work. Either I'll find something for it, or, perhaps, we can figure out how to make a version run with an MS-DOS - I'm pretty sure the program won't care, they likely did it that way because of some MS royalty situation!
m
0
l

Best solution

a c 177 V Motherboard
June 22, 2010 4:54:05 PM

OK - the Caldera thing at least gave me some clues, Caldera used to do an RTOS as well, and have (tiny) experience; latest is 7.03, and didn't give me much hope - d/l'd 7.02 - no USB drivers whatsoever...

Just as an aside, might want to bookmark these:
Caldera DOS User's Guide...
Club Dr-DOS 'USB in DOS' wiki

Found some stuff that should work (yeah, I know, famous last words :pt1cable:  ); put 'em together in one, self-extracting file here...

Will extract to three archives:
usbdos.zip
cutemouse21b4.zip
cutemouse191.zip

usbdos.zip contains a file called "USBMOUSE.COM", which is sort of a USB->PS2 'translation driver', but still requires a mouse driver itself. The guy who wrote the driver recommends 'ctmouse' [CuteMouse], and the reason you have two archives is that he says versions 19 and less, or 21 and higher will work - don't know if there'll be a difference, figured - may as well have 'em both! The files you want there are in the 'bin' directories of the archives, called "ctmouse.exe"...

Lots of config options, but from a 'cursory pass', should work simply with defaults - CuteMouse 'searches' first for a mouse on the PS2 ports, which USBMOUSE should be emulating. I would suggest (if there's room on your boot disk) to extract the ctmouse files, rename them CTM19.exe, and CT21.exe, so you can change easily if needed. Copy both of them and the USBMOUSE.com to the booot disk. Want to mod your autoexec.bat to read:

REM Windows DOS:
REM MSCDEX.EXE /D:D river_name [/L:D rive_letter] [/M:buffers]

REM Caldera DOS:
REM NWCDEX.EXE /D:D river_name [/L:D rive_letter] [/M:buffers]

MOUSE

USBMOUSE.COM
CTM19.EXE
(or CTM21, if 19 doesn't work...)

SET TZ=PST8PDT7,M3.2.0,M11.1.0

ECHO.
ECHO Insert Drive Image Disk 2 (Program)
ECHO.
ECHO.
ECHO *** Press Any Key to Continue ***

Hopefully, that should give you USB mouse...
...good luck!
Share
June 22, 2010 6:25:33 PM

Great, thanks.

I see you survived the storm!

Give me some time and I'll digest your info, and also give cutemouse a try. I've read about it online, haven't tried it.

I'm out of my league with the DOS commands...some studying is in order.

Again thanks for all of your help.
m
0
l
a c 177 V Motherboard
June 23, 2010 4:15:32 AM

Always !

Overall, wasn't too bad (for a tornado! :heink:  ) - six or seven houses razed, trees and powerlines down in huge numbers, twenty or thirty thousand homes w/o electricity, but - big thing - NO CASUALTIES!! [:jaydeejohn:3]
m
0
l
June 23, 2010 4:25:50 PM

Wow, sounds like tornado alley. When we were stationed in Okla City, and a tornado was forecast, we'd fly all the airplanes to some safe area...and leave the families behind! Feel free to contact me anytime, I am kernel64@

Ok, I've solved the problem. I returned the board for a new one. They didn't have another exact same model, so I exchanged it for a GA-790XDA-ID4, mostly because that board has all the features I wanted and it also has two PS2 ports.
Works like a champ. By the way, Gigabyte finally answered my message about only one PS2 port and no legacy USB although it was enabled in BIOS. Their answer is a classic: "The board has a single PS2 port that you can use for either a keyboard or a mouse." That was it, in total. I'm with cox.net
m
0
l
a c 177 V Motherboard
June 23, 2010 8:39:19 PM

Spent some time in Wichita Falls, TX & 'wandered' on weekends to OC - was amazed by the definition of 'cellar'! Here in Wisconsin, nearly every house has a basement... Older folk, like me, (and I think, mainly of German extraction) call 'em 'cellars'; grew up farming with German grandparents who had a cellar, and then, inside it, had a 'root cellar' (where you stored onions, potatoes, and other tubers year-round), and a 'coal cellar' for the coal-fed furnace. Was awe-struck when the 'tornado alley' dwellers showed me what they meant be 'the cellar' - solid concrete, tiny 'blockhouse', with a welded-hinge steel door, buried in the yard, that you crawled into when the monthly tornado swarm passed through! Looked waaayyy too much like a 'tomb' for my tastes!

I kinda think, at least in the short-run, 'till they get the 'newness' sorted out, you'll be happier with the 790-based board, anyhow... Seem to be a few 'peculiarities' with the 890's yet, biggest one I've seen so far is strange behaviour with seven and AHCI-mode drives - sort of seem to work sometimes, and not others, without (apparent) 'rhyme-or-reason'.

The GB support is typical for 'first line'; far as I can figure out, their support is 'tiered' - first 'go around' they're geared for dealing with illiterates who can't/haven't read the first page of the manual :??:  They can provide meaningful, decent support, but it takes several exchanges with 'em to 'burrow down' to that level...

Had to mention: Blue Angels were here in town last week. During a practice run, 'dipsy-doodle' news station I watch reported they had an emergency landing, due to a bird strike; they made sure to mention "fortunately, no one was hurt", and I wondered, "did anyone think to ask the bird about that notion?"! [:bilbat:9]
m
0
l
June 30, 2010 4:57:36 PM

Best answer selected by kerneldebugger.
m
0
l
a c 177 V Motherboard
June 30, 2010 5:49:48 PM

Have to mention: have the exact, same problem! Just got a GA-H55M-USB3 in to do a system for someone - has only one PS2! Have a 'pre-boot' utility that has its own USB drivers, but USB mouse will still not work - doesn't 'like' the H55's USB ports, apparently [:lectrocrew:7]
m
0
l
!