Sign in with
Sign up | Sign in
Your question

Formatting LOCKED to NTFS?! Help!

Last response: in Storage
Share
November 11, 2011 3:46:32 PM

Hey guys!

I've been searching online for hours without finding a solution so here I am; google (or my common sense) has failed me.


I bought a 500GB portable hard drive yesterday hoping to use it with my car radio, which supports it. Now here's the cool part : The Iomega Prestige drive that I got natively protects the drive with AES 256-bit, so the radio couldn't detect it, as it usually boots a Virtual CD into windows as if it were firmware. I contacted Iomega, and they told me that the new version of their encryption firmware/software has the option to remove the protection without ruining the drive.

So I manage to update the damn thing, and remove the virtual CD.

My radio obviously does not have a windows file system so the only format that makes sense using is FAT32. Before removing the Virtual CD, I could format the 500GB to FAT32 without any issues (using third-party software). Now, not only is exFAT not available in the Windows formatting tool (which would worthless anyway), every software I've tried cannot detect the external hard drive which is in NTFS.

This is first time I've seen a drive that cannot be formatted to another format so I am completely lost. What could cause this? How can I format it? Some posts on other forums recommended using XP to see if the options are diffrent, so I'm currently installing an XP Virtual Machine to see if it works.

So what's going on? Thank you for enlightening me!

Patrick

More about : formatting locked ntfs

a c 371 G Storage
November 11, 2011 3:58:19 PM

I'm not sure why you are having problems, but as you know, windows can't/won't make a fat32 partion bigger than 37 gig I believe it is. i've used this utility in the past with great success. It doesn't look like much, but it has worked for me. Delete all partitions, then create new ones. Fat32 has a 2Tb partition limit, but you should be fine as you only have a 500gb drive.

http://tokiwa.qee.jp/EN/Fat32Formatter/
m
0
l
November 11, 2011 4:01:54 PM

I've tried that application as well. However, I should point out that it is the only application that actually detects the drive. I get a bunch different error messages that change every time I try.

One of the biggest bugs was this : FSCTL_LOCK_VOLUME failed!

I managed to initialize the drive, but when I click format, I get these error boxes :

#1 : The parameter is incorrect.
#2 : Fat32WriteBootSector#WriteFile1 Failed
#3 : Fat32WriteBootSector() failed!
#4 : Error in StartFormat
#5 : Failed to format partition!

These messages follow each other in a logical order, seems like software was programmed to show each message when one thing went wrong, but the start failed for me ^^.

What could be causing this? There's debug version of this software on the site, I'll try this, but keep the solutions coming. Thanks.

m
0
l
Related resources
November 11, 2011 4:48:05 PM

Alright, I managed to format the drive to FAT32 using another computer, still isn't possible if I revert using my desktop. :o 


I don't understand any of this... :sweat: 




But the radio still isn't seeing the drive, maybe this one pulls too much power... :heink:  back to troubleshooting it is :( 



*EDIT : Nope, not a power issue...
m
0
l
a c 415 G Storage
November 12, 2011 12:29:39 AM

Are you sure the radio supports a FAT drive that large? Consumer devices don't have a lot of internal memory to hold firmware and they often aren't designed to be as flexible with drive characteristics as a computer is. Radios with USB ports are generally designed to deal with relatively small USB flash drives and yours might well not handle something as large as 500GB.

Try formatting the drive with a plane-Jane FAT partition of just a few GB and see if the radio recognizes it. If it does, then you can try larger and larger partition sizes until you find out where the radio "looses it".
m
0
l
November 13, 2011 9:23:25 PM

Yep, that's what I've started doing, I've formatted to 32GB just to see if it will see it, but from looking at other forums, it seems to depend on the drives, I've seen someone with a 1TB HDD plugged into the same radio, and a lot of people have listed 160, 250 and 320 GB drives so it should work, but my fear is that it will take a heck of a long time getting the list generated (the radio reads the content upon every boot). It takes about 3 minutes for the damn thing to boot my 32GB Patriot USB flash drive, probably going to have to wait an hour for 500GB... Can't even imagine how long it will be during winter @ -20C temp.

Anyway, I'll try to see if I get the thing to see it.
m
0
l
!