Sign in with
Sign up | Sign in
Your question

SATA Cable Mix Up On RAID array. HDD is requesting format

Last response: in Storage
Share
November 15, 2011 12:15:55 PM

Hello,

This is my first question on here, although I have used your forums for answers before, I have searched for the answers on this and I may just be using the wrong search terms. It's quite a while since I last got my head around this so I'm rusty.

Background:
-M2N SLI Deluxe MOBO, Windows 7 OS
-I have 5 physical HDD's, 2 are bootable and are made RAID using MediaShield in the BIOS. 2 more were made striped/or mirrored in Windows 7, the 5th is a single disk. All "drives" have multiple partitions
-I removed the cables to the non-booting array and single disk to address a graphics card issue (now resolved)
-I do not remember what order the sata cables were plugged in.
-The bootable RAID array (STRIPE) is in SATA 1 and SATA 2, the CD/DVD ROM is in SATA 6.
-I resolved the graphics card issues with just the bootable array in place, this is now resolved and system is stable

Problem:
-I reconnected the HDD cables in (probably) a different order to which they were before
-I cannot remember whether I set the second RAID array as MIRROR or STRIPE (I think it was STRIPE)
-The computer is now VERY CONFUSED and I cannot access data on any of the 3 (non bootable) drives

When I first rebooted with all 3 drives plugged in, I got a message after booting that said that new HDD's had been detected and I needed to format them before I could use them...I have NOT formatted them
Tried looking in Disk Manager and they appear to be completely unused disks, although one of the 2 from the RAID array shows partitions, I cannot access the data, the other disk from the RAID array says it needs to be initialised (I have NOT done this)

In an attempt to remedy the problem (after some rooting on forums) I have tried a few different loose ideas to fix this, for example I have tried, a selection of orders for the cables (Trial and error) some combinations resulted in the computer not booting and then using Windows RE (from the Win7 disk) to fix BOOTMGR.

I just need to know if there is a way I can check what kind of array it was and put it back together without damaging the data, this seems like a mad bug, I would have thought Windows could recognise a disk, and there is no way that 3 hard drives have failed at the same time, they all show as "healthy"

The drives are WD Caviar types, and are identical

Can anyone help me with this, what is the best way to resolve this problem, I'm worried that keeping swapping the cables around randomly is causing MORE problems.

The system boots fine with just the OS array in place, but will do anything from hang, tell me that BOOTMGR is missing, or boot up and show the disks need formatting when I try different cable combinations.

Please help

!