Sign in with
Sign up | Sign in
Your question
Solved

What the.. my 5970 won't run L4D2?

Last response: in Graphics & Displays
Share
December 11, 2009 6:06:00 AM

Before I load up the game, Steam says that it doesn't recognize 5900 series cards.

In the menu, I maxed out all settings and set my resolution to 16:9 1920x1080 (for my Viewsonic 24")

When I try to load up the first level, a kind of "static screen" shows up, and I can't return to the Windows desktop so I had to manually shut down.

What do I do? Here are my system specs:


Intel Core i7-920
Diamond Radeon HD 5970
Patriot DDR3 6GB 1333MHz Tri Channel
Gigabyte GA-EX58-UD3R
Corsair CMPSU-650TX- 650W
WD 750GB Serial ATA/300HD, 32 MB buffer
Cooler Master HAF 932
Lite-On 24X SATA DVD-RW Gen II
Netgear WG311 G PCI 54 Mbps Wireless-G PCI Adapter
Windows 7 Home Premium

More about : 5970 run l4d2

a b U Graphics card
December 11, 2009 6:34:28 AM

Contact L4D2 support or ATI support.
m
0
l

Best solution

a c 106 U Graphics card
December 11, 2009 3:10:15 PM

^+1

In the mean time try lowering the settings and see if you can't find one that works. Could be a memory allocation issue.
Share
Related resources
a b U Graphics card
December 11, 2009 4:06:48 PM

Newest drivers and patches? I'd try reinstalling the video drivers and the game (and by reinstall the game, I mean uninstall and manually delete all config files). Was this an existing install that got a 5970 added to it or a new build?
m
0
l
December 11, 2009 4:56:05 PM

I think you should send your pc to me, and i'll try to figure out your problem.
really though, that's actually not the kind of thing we can fix....
so +1 for hellstorm
m
0
l
December 11, 2009 5:47:11 PM

ckim2116 said:
Before I load up the game, Steam says that it doesn't recognize 5900 series cards.



I would also recomend looking for an update for steam. The 5000 seriers cards and drivers are not very stable right now in comparison to other cards avaliable. This is probably just a matter of waiting till it is fully supported by steam.
m
0
l
December 11, 2009 9:46:04 PM

Lowered the settings and works fine. Though it's annoying that I have a 5970 and can't max out a game that's not particularly graphics intensive :( 
m
0
l
a b U Graphics card
December 11, 2009 10:24:40 PM

Well, like it said, it didn't recognize your card so it didn't know it could do it. That will probably get fixed eventually maybe.
m
0
l
January 2, 2010 9:42:31 PM

Similar to your situation, though L4D2 DID recognize my 5970, it seemed to stutter/jitter around like it couldn't handle all of the max settings. I thought it was silly when it couldn't do that and actually thought maybe I had some other program running in the background causing extra stress. So I Alt-Tabbed out for a moment, and then back in, and Viola! It started running smooth as butter... at least until it loaded the next map, then the same thing happened again. So I just tried the Alt-Tab thing again, and voila, it was working again. So I've just narrowed it down to a drivers issue more than anything else. Something is not refreshing right or something in L4D2 but when I Alt-Tab out and back in, it kicks it into working like it should. I don't mind doing this once per map as it only takes a couple of seconds, but it's slightly annoying. Yet, I've never seen this problem on any other game I've played either, it's only on L4D2. I have the very latest drivers, so now I'm just waiting for a fix and better drivers in future releases. Not really sure what else to do as I said, everywhere else it works fine.

Sorry to open a somewhat old thread, but I just thought my experience may help someone else who's been frustrated. :-)
m
0
l
January 3, 2010 1:02:23 AM

LittlBUGer said:
Similar to your situation, though L4D2 DID recognize my 5970, it seemed to stutter/jitter around like it couldn't handle all of the max settings. I thought it was silly when it couldn't do that and actually thought maybe I had some other program running in the background causing extra stress. So I Alt-Tabbed out for a moment, and then back in, and Viola! It started running smooth as butter... at least until it loaded the next map, then the same thing happened again. So I just tried the Alt-Tab thing again, and voila, it was working again. So I've just narrowed it down to a drivers issue more than anything else. Something is not refreshing right or something in L4D2 but when I Alt-Tab out and back in, it kicks it into working like it should. I don't mind doing this once per map as it only takes a couple of seconds, but it's slightly annoying. Yet, I've never seen this problem on any other game I've played either, it's only on L4D2. I have the very latest drivers, so now I'm just waiting for a fix and better drivers in future releases. Not really sure what else to do as I said, everywhere else it works fine.

Sorry to open a somewhat old thread, but I just thought my experience may help someone else who's been frustrated. :-)


That's called micro-stuttering, which is a normal for multiple graphic card settups.
m
0
l
January 3, 2010 1:59:38 AM

I've had a dual Geforce 295 GTX SLI setup before and never had any problems like that. Now, with this new SINGLE 5970 (though it technically is two cores and whatnot), I get this with the game. In either case, I would never consider such a behavior as "normal". "Normal" behavior would be the game working as it should without having me to Alt-Tab and force it/make it work. It's unplayable as it skips and stutters around. It's like having a high lag or a very old graphics card trying to power max settings. It's unacceptable in my opinion, but my workaround is fine since it always works and only takes a couple of seconds. I hope there's a permanent solution in the future, soon, but this will have to do for now. :) 
m
0
l
January 3, 2010 5:22:03 AM

I just turned the graphics down to normal and it worked fine from there. I doubt there's a big difference if you max out settings on L4D2 anyway.
m
0
l
!