Sign in with
Sign up | Sign in
Your question

[Solved] Problem with rebuilding RAID1

Tags:
  • NAS / RAID
  • Storage
Last response: in Storage
Share
November 15, 2011 3:54:57 PM

Hello everyone.
This is my first post hear and I have to apologize in advance if my english skill isn't good enough.
I will try my best to describe the details of my problem so everyone will not get a headache.

My PC Spec:
CPU: AMD Phenom II B55 (@ x4)
Motherboard: M4A88TD-V EVO USB3
Harddisk: two WD Green 1TB (EARS:Sata2) as RAID1 for data storage (I named this as ES : single partition that used all space of RAID1) and Samsung 103SJ 1TB for os.
OS:Windows7 Ultimate 64-Bit

- RAID1 was build from bios or something that was bulit-in with motherboard
- Use AMD RAIDXPERT to do thing such as syncronization and rebuilding
- Monitor disk condition by hd sentinel that show S.M.A.R.T and disk's health



My RAID1 has work properly for almost a year and some time I had to rebuilt RAID1 due to my clumsiness but there was no major problem that I can't solved by google(d) and tried by myself.

Today's problem is quite differrent and I can't solved by myself though.

The problem occured by this procedure...
- hd sentinel show that S.M.A.R.T of one of the disk in RAID1 is go wrong (C6 offline uncollectable--> 1 point in this field) but no problem in read/write data on the RAID1
- Out of curiosity, I want to remove/correct the problem and try to zero-filling the disk that S.M.A.R.T go wrong so I will call the disk as the wrong(ed) one.
- I shutdown my pc and disconnected the good one (I mean one of the disk in RAID1) and the wrong(ed) one still connect.
- I set up SATA controller from SATA to IDE so I can mess up with the wrong one and hope nothing go wrong with the data in good one
- I used WD data life guard to zero-filling the wrong disk --> when finished I shutdown the pc
- turn on pc and switch SATA controller back from IDE to RAID

After the procedure above the problem showed up.

The boot screen showed that my RAID1 (I called it as ES) is in critical stage as the data was not syncronized properly definitely caused by zero-filling the wrong one (and all data in the disk are gones).
In windows's computer management (disk management), it saw ES as disk1 and in the state of uninitialize disk while in RAIDEXPERT and BIOS RAID setup screen saw the RAID1 as funtional.

I can't remembered correctly that what I have done, but it end up that in disk management, it saw good one as uninitialize disk (show as disk 2) with unallocate space while it saw the wrong(ed) one as initialized disk (show as disk 1) with unallocated space.
To fill more detail, I can't access data in both disks due to they were showed as unallocated partition and have no drive letter yet.

I try to rebuild RAID1 by hope that the good one is the base of rebuilding.
The problem is whenever I connect both disks at the same times and tried to use the rebuild function in RAIDXPERT, it always showed that the wrong(ed) one with no data is the base disk that assigneded to RAID1) while the good one was marked as unassigned one.
If I rebuild at this state, I think RAIDEXPERT will write the good one (with data) by the data of the wrong(ed) one that has no data, so I stop and try to ask someone before causing more problem.

The strange thing is when I connect only the good one, RAIDEXPERT saw the good one as assigned one though.

The point is I want to use the good one that has data as the base to rebuild RAID1, not the wrong(ed) one with no data.

By the way, in RAID setup screen when boot up my pc (when I push ctrl+f) show that the wrong(ed) one is LD 1-1 while the good one is LD 1-2.


I hope my language and explanation are good enough so someone can understand and help me solv the problem.


The datas are important to me because they contain a lot of my family's pictures from many years ago.
Please, someone please help me. I don't wanna lose my precious picetures that carry our family memories.

More about : solved problem rebuilding raid1

a c 78 G Storage
November 17, 2011 7:38:48 PM

With ONE drive can you access your data?

If you can then, format the other and use the back up program instead, schedule is as often as you can...

i would refer this this way rather RAID1
m
0
l
November 19, 2011 4:28:27 AM

I couldn't access my data in either the good one or the wrong(ed) one because computer management saw theire partition as unallocated.
The same result goes for both in RAID and IDE mode in bios sata controller.



Update!!
Now I successfully rebuilt RAID1 by using the good one as base disk.
Before that computer management list the partition of raid mirror drive as unallocated but I rebuilt the wrong(ed) one eventhough I knew about that.

As a result of successfully rebuilt RAID1, when I boot my pc it show that the RAID array is functional and RAIDXPERT also show the same result.
Sadly, computer management still list the RAID mirror drive as unallocated.

I wonder that the rebuilt wrong(ed) one contain any data from the good one.
Because the good one that was used as base disk to rebuild was listed as unallocate.

I still wait for someone to give me solution. Please help me.
m
0
l
Related resources
a c 78 G Storage
November 19, 2011 9:21:15 PM

If the RAID volume NEVER initialize or format.. change are the data still there, you just lost the HDD index/FAT section... any recover data program should be able to see the data
m
0
l
November 20, 2011 4:26:59 AM

Thank you for your suggestion.
I tried Acronis Disk Director 11 and Easeus 8 but both couldn't solve this problem.

Could you recommend any application or utility that work out with my problem.
m
0
l
November 24, 2011 7:49:19 AM

bump
m
0
l
November 28, 2011 4:01:17 AM

The problem was solved!

At first, I couldn't figure it out because I thought there was something wrong with RAID controller while the true reason of the problem was corruption of partition table in the good disk.
As a result, the bad(ed) disk that was rebuild, cloned all data from the good one's that also include the corrupted partition table.
After I recovered the data, I just laughed quietly to myself and wonder that why the hell I mixed up this problem with RAID stuff.

When I figured the cause of the problem, it was quite simple how to solve the problem though
I just use a freeware app like testdisk to rebuild the partition table on the disks.
The process was simple but it took at least 4 to 5 hour to analysed the disks before rebuilding.
I am not sure that analysis is the prerequisite process to rebulid the partition table or not.



From this nightmare, at least it proved me that rebuilding of RAID1 will clone everything from the source disk to another disk no matter what happen to the partition of the source disk as long as both disk are healthy.



Thanks you for everyone who try to help me.
I hope my blabber can help someone to figure and solved the same problem.

By the way, is there some way to edit the topic's name? I wanna edit it as solved topic so that no one will waste their time to help me solve the solved problem.
m
0
l
!