Sign in with
Sign up | Sign in
Your question
Closed

Two sata drives -- tried to choose boot order in BIOS setup, but doesn't seem to

Last response: in Storage
Share
November 16, 2011 12:07:38 AM

So, one of my desktop computers went belly up -- won't turn on at all. I switched the power supply and tested the switches, and that doesn't seem to be the problem. So, it's probably MOBO or processor. At any rate, I want to take the 160MB Seagate SATA from that machine and install it in my other desktop to transfer all the data. But when I install it in my other desktop, it tries to boot from the Seagate rather than the other SATA, and won't start Windows normally, undoubtedly because they have two different MOBOs so the drivers are different. I went into setup, and switched the boot order of the drives so that the 250MB drive was first, but it still won't start Windows normally until I disconnect the 160MB "foreign" drive. Do I need to switch a jumper on the drive or something?

Best solution

a c 167 G Storage
November 16, 2011 12:23:00 AM

Sata has no jumpers you need to change for booting.

When you switched the boot order, did you save the new configuration?


If you can't figure it out, switch the sata cables and see if you boot properly.

If all else fails, mount the 160gb drive in an exterhal usb enclosure and plug it in after booting.
Share
a c 342 G Storage
November 16, 2011 4:07:26 AM

When you go to the Boot Order setting in BIOS, you should NOT be forced to put all the drives into the sequence. You should be able to set it to try the optical drive first, your 250 GB drive second, and NO other units after that. Then BIOS will not try to boot from the 160 GB unit.
Score
0
Related resources
Can't find your answer ? Ask !
November 24, 2011 4:12:50 PM

Paperdoc said:
When you go to the Boot Order setting in BIOS, you should NOT be forced to put all the drives into the sequence. You should be able to set it to try the optical drive first, your 250 GB drive second, and NO other units after that. Then BIOS will not try to boot from the 160 GB unit.


In the setup screen I go to by pushing F2, it allows me to move drives up or down in boot sequence, but it doesn't allow me to delete drives from the sequence (at least not in hard drive boot sequence submenu). I agree that it should let me do that, and that your suggestion would be a great one if it did, but I can't seem to find that option.
Score
0
November 24, 2011 4:33:13 PM

geofelt said:
Sata has no jumpers you need to change for booting.

When you switched the boot order, did you save the new configuration?


If you can't figure it out, switch the sata cables and see if you boot properly.

If all else fails, mount the 160gb drive in an exterhal usb enclosure and plug it in after booting.


I know I saved the configuration, because upon rebooting, if I go into setup, the 250MB shows up in the boot sequence before the 160MB.

The happy news is that switching the cables worked, which seems really weird to me. If the 250MB was plugged into a particular SATA port and was first boot when it was the single drive, why would I need to switch it? But it worked! :D  For now, it will allow me to backup all the files, and at least function until I debug the other problem.

Thanks, geofelt.
Score
0
November 24, 2011 4:33:29 PM

Best answer selected by saundja3.
Score
0
a c 180 G Storage
November 24, 2011 4:36:59 PM

This topic has been closed by Area51reopened
Score
0
!