Sign in with
Sign up | Sign in
Your question
Closed

Keyboard works, but won't type

Last response: in Windows XP
Share
June 23, 2012 2:16:12 AM

Hello,
So I have a DELL desktop computer (Windows XP), and the keyboard won't type anything (obviously, I am using another computer at the moment). I know it still works, I hooked it up to another computer and it works fine. I've tried keyboards that work on other computers, but they won't type on my computer. Also, when I try to type, the computer makes boob sounds that computers make when they cannot perform a function.
Also, I turned my computer off a few days ago, hoping that it would work if I turned it back on. of course, it wouldn't type still, and now I'm locked out because I can't type in my password.
I'm wondering if I accidentally hit some combination of keys or something that made it so my computer wouldn't process what I type. So is there a way to fix this? Keep in mind I can't access much because like I said, I'm locked out.
Thanks

More about : keyboard works type

June 23, 2012 3:47:34 AM

if its a PS/2 keyboard you may have fried the i/c chip. try a usb keyboard instead.
December 18, 2012 5:00:59 PM

well i have the same problem. I have tried numerious USB keyboards and wireless keyboards. Mouse works but not the keyboard.

wondering if some time of virus or malware is causing this.

How do we get the keyboards back to working. The machine just beeps each time i type a key....

have tried activating the on screen keyboard (Win 7 pro) but that does not seem to work either.

HELP?

Dave Willis
dbw@pobox.com
Related resources
December 22, 2012 4:47:42 PM

Not a solution but just passing along that I am having the same problem just recently. XP OS.
Primary kbd is usb, I have tried different usb ports on PC that I know work and kbd doesn't type.
I've tried another kbd I know works from another system AND is PS2,also doesn't work.
The wireless mouse works via usb.
In device properties I have deleted the drivers, plugged the usb kbd in, system recognizes kbd, auto reinstalls the right drivers and says device is ready for use. Looking at properties, the device says it's working correctly.
In properties for kbd, I do notice that the drop down list for either setting device enabled or disabled is grayed out.....but I don't know if that option was ever available to change.

Waiting to see if anyone posts other solutions per your question again.

Thanks Dave L
December 22, 2012 6:21:46 PM

Are you sure that the correct type of keyboard has been selected in the BIOS (or on installation of the OS). Sometimes having the wrong keyboard type selected can give faults. Default is US standard keyboard layout.
May 2, 2013 5:31:22 PM

go to your control panel. then, if it is there, go toease of access. Change the keyboard settings to this.
-Turn off mouse keys
-Turn off filter keys
-Everything else keep on
May 2, 2013 10:58:53 PM

That option isn't available in XP dragonfire but this old thread has run its course and is being closed now. It's best only to post into threads where the last reply is less than three months old.
October 6, 2013 3:07:09 AM

just hold the right shift key for 8 sec and it will work fine ! :wahoo: 
!