Sign in with
Sign up | Sign in
Your question

Connected SATA hd to IDE mb using IDE adapter works but...

Last response: in Storage
Share
November 16, 2011 4:54:02 PM

Hello,
I have connected a SATA hd to an IDE mb using a generic IDE adapter. It boots up and works perfectly and I've installed windows on it successfully, BUT
when I try to add an older IDE drive as a slave on the same ATA cable and boot up, the mb doesn't see either drive.

I've tried setting the boot selector, I've tried setting the jumper on the IDE to cable select (and using gray connector - sata with the black connector), the IDE adapter on the SATA drive has only 2 pins with a jumper that identifies it as the master. I think I've tried every jumper combination, but still won't boot up if both are connected.

MB only sees the SATA drive as a slave when both are connected, and even with this setting I've set the boot sequence to see the SATA drive as the only hd to boot from, but still won't boot up. Only if I disconnect the IDE drive will the SATA drive boot up to Windows normally.

I just need to get data off of the IDE drive. Previously, it was the slave to the old IDE drive that I replaced with the SATA drive.

Any ideas? Thanks in advance.
a c 342 G Storage
November 16, 2011 5:56:10 PM

Well, this may seem an odd suggestion, but you have not tried it yet. For whatever reason, it appears the adapter you are using makes the SATA unit appear to be the Slave on the IDE port. So go with that. Plug it into the Grey middle connector on the ribbon cable. Then set the jumper on the actual old IDE drive to be Master and plug it into the Black end connector. See if that will allow the BIOS to detect both properly. Make sure the Boot Sequence is set to use the SATA unit as the only HDD boot source (maybe after your optical unit), as you have done before. You will need to check this, though, since the sequence setting often actually remembers the device location to boot from, not the device identifier. You would not want it trying to boot from the IDE port new Master, which is your OLD IDE drive in this configuration.
m
0
l
November 17, 2011 8:17:18 PM

Thanks for the suggestion... I tried it, but no luck either, although the BIOS sees both. BIOS shows the old IDE as master, and SATA as slave, and I set boot sequence to the SATA. After reboot, it just hangs... no black mb info screen and definitely no windows splash screen.

I'm just going to bite the bullet and try one of the IDE to USB adapters out there.

Thanks again for the suggestion!
m
0
l
!