Sign in with
Sign up | Sign in
Your question

ASRock won't flash BIOS. Just hangs. Otherwise okay.

Last response: in Motherboards
Share
June 27, 2010 5:08:06 AM

I have an ASRock M3A770DE AM3 AMD 770 ATX AMD Motherboard that won't let me flash the BIOS.

It seems I caught a virus a couple of days ago. I ran every malware killer I could find but finally gave up and just reformatted the disk. Afterwards, everything seems to work fine: no sign of a virus.

But apparently reformatting wasn't enough. Now the motherboard POST and Windows boot screen both take at least 60-90 seconds each, upwards of 3-5 minutes just to boot the computer. I think it got a hold of the BIOS, causing the slowdown. Despite everything else being normal, it's still annoying, especially when installing new drivers.

I went to try and flash the BIOS but it won't take. I thought the screen was just slow loading, saying "Checking [New BIOS file]. But it just hangs indefinitely.

Should I use a 3rd party utility? If so, what kind?
a c 435 V Motherboard
June 27, 2010 10:31:19 AM

Check the bios settings. Be sure "fast boot" is enabled and "lan boot" is disabled. The bios could also be searching for a device that you don't have installed in your system, causing the delay, so check your settings carefully.
m
0
l
a c 217 V Motherboard
June 27, 2010 4:24:05 PM

First, malware can't do anything to the BIOS. As o1die indicated, after a BIOS flash you should verify your settings to make sure your configuration is correct. I recommend turning off things like serial and parallel ports if you aren't using them, as well as disabling boot devices (like the network) that you don't use.

You should also verify that all of your hardware devices are installed properly and that all of your drivers are up to date. Now that you have a new install, you may need to download many of your drivers to update them as well.

Last, double (no triple) check that you have the right BIOS for your motherboard by model version number (i.e., V1.1 or V1.2, etc). Many manufacturers have multiple hardware versions of the same model number of motherboard. You must have the correct version to install properly.

I assume you are trying to use the Windows flash utility from ASRock, I have seen flaky versions from them in the past. You may have to use a different (DOS) version an an alternative.

Check these out should reduce your boot times dramatically. Good luck!
m
0
l
a c 217 V Motherboard
June 27, 2010 4:26:52 PM

BTW, what version of BIOS is currently installed and what version are you attempting to install? Current version appears to be 1.60 and comes in 3 flavors (Instant Flash, DOS, and Windows). What versions have you tried to use?
m
0
l
!