Asus P5KPL-CM stuck on bios

When i startup my comp, it gets stuck on
Auto-detecting USB Mass Storage Devices
Device #01:
It never gets pass it. Please help.
32 answers Last reply
More about asus p5kpl stuck bios
  1. Anything connected to a USB port (internal or external)? If so, then disconnect it. If that doesn't help, then reset the BIOS. The next step is to remove all non essential components to determine which one causes the issue.
  2. I have a printer mouse and keyboard in the USB ports.
  3. What happens if you disconnect them? Same issue?
  4. I disconnected my printer and it boots up. But is there a way to make the BIOS boot up with disconnecting my printer?
  5. You might have to change a setting in the BIOS. Refer to your manual or contact Asus support.
  6. I contacted Asus support and they weren't cooperating.
  7. Have you tried connecting the printer to a different USB port?
  8. Yes and also my printer is a 3 in one fax, scanner and printer. It also has a card reader.
  9. It might be the card reader part that's causing the issue. Check in the BIOS if your system can boot from a USB device and, if possible, disable that feature.
  10. I found something in the boot tab that said something about which device to boot (CD or DVD etc.) and it said Removable Device (or something similar. Should i remove that?
    EDIT: Never mind didn't make it faster.
  11. Do you mean that when the printer is connected, the system eventually boots after a long delay?
  12. I don't know because i've waited for like 5 minutes and i gave up.
  13. I guess there is no permanent solution to your problem. Does it make a difference if the printer is powered off or powered on?
  14. Where can i find the boot from usb option from the BIOS? I'm using Asus p5KPL-CM using Phenix bios.
  15. That should be indicated somewhere in the manual, but at a minimum the printer (or anything connected to it) shouldn't show up in the boot device list. If you hibernate the system, do you still have the issue when you power up?
  16. Srry for the l8 reply but there is no hibernate in my computer.
  17. Hibernate is a feature provided by the OS.
  18. I don't see hibernate in my os.
  19. I put the power option on High performance
  20. There should be a setting to enable Hibernate when you power off. How did you configure power in the BIOS?
  21. I didn't really configure the power i just changed the overclocking settings.
    Edit: I can see Suspend mode, something about ACPI and APN Configuration under Power.
  22. But are they configured correctly?
  23. I didn't touch anything cause i don't know what to configure
  24. You should at least be able to tell us what the current settings are.
  25. Here are the current settings.


  26. Enable ACPI 2.0 Support to see if it resolves the issue.
  27. Remove your hard disk and try turning it on and see what happens,I am using an asus p5kpl am ps and my bios also got stuck when my hdd burned,So try this and came back to the forum!
  28. Still doesn't work
    @Aneesh@4GHz Its about my printer not my hdd.
  29. Then there isn't much else that can be done. If the system can't disable booting from USB and other settings have been verified, then there's a compatibility issue.
  30. If i disable removable device from the boot order will it disable detecting usb?
    I have tried disabling Legacy USB and it worked but because I dual-booted my computer i can't choose which Windows to boot into. Is there a way to solve this?
  31. Try to disable removable devices to see if it helps.

    Can't you press F8 at POST and then select the disk to boot from (assuming that both OS are on a different disk)?
Ask a new question

Read More

Asus BIOS Storage USB Devices Motherboards