Sign in with
Sign up | Sign in
Your question
Solved

Getting "the driver package is not signed" error on install of 3850agp

Last response: in Graphics & Displays
Share
December 12, 2009 7:37:53 PM

I did a fresh install of XP 32 bit after using Win 7 because I want to play certain games that won't work on the new OS. I have SP3. I'm trying to install my display driver for the sapphire 3850 agp. But when I try to install both the 9.11 drivers and the hotfix drivers it just "skips" the actual driver install, finishes, and the error log shows that it didn't install because the "driver package is not signed". I even tried installing older drivers that don't use the install manager but that didn't work either. I've tried searching for a solution but can't find anything similar to my problem.

If anyone could point me in the right direction I would really appreciate it.
a b \ Driver
December 12, 2009 7:46:11 PM

ltj311 said:
I did a fresh install of XP 32 bit after using Win 7 because I want to play certain games that won't work on the new OS. .



Which OS is that ? Win7 pro / Ult has "XP Mode"

But when I try to install both the 9.11 drivers and the hotfix drivers it just "skips" the actual driver install, finishes, and the error log shows that it didn't install because the "driver package is not signed".

Was your fresh install ona freshly formatted HD ? If nt clean out your machine usinga driver cleaner or registry problem solver like CCleaner.
m
0
l

Best solution

December 12, 2009 8:06:30 PM

Drivers for AGP radeons need the hotfix. Since they are basically hacked from the original drivers manufacturers haven't bothered to sign them. The first time you tried to install it the system may have warned you that it was unsigned so you clicked on stop installation and now it won't even bother with the driver. Anyway....

You're going to have to manually install the driver. Go to the control panel, go to system, and go to device manager. Click on the "+" on display adapter. Double click on the display adapter listed or rightclick and select properties. Click on "Reinstall Driver". Click on "Manually Select Driver" or something like that. Click on "Have Disk". Navigate to wherever the catalyst installer unzipped the files, usually C:\ATI\Support\ whatever driver version. Just click along and make sure you click on the correct buttons to install the unsafe, unsigned driver rather than heeding the warnings :D .
Share
Related resources
December 12, 2009 8:46:02 PM

@JackNaylorPE

It was Win 7 Ultimate but I never tried the XP mode. I did a reformat of my hard drive and did a fresh install.

@megamanx00

What a simple fix. Thank you so much. I installed the 9.11 hotfix through device manager like you said and it worked perfectly. Didn't even have to restart my computer. You are the man!
m
0
l
December 13, 2009 4:04:58 AM

Glad you got it working. Happy gaming.
m
0
l
!