Sign in with
Sign up | Sign in
Your question

Power button on front of case not working

Last response: in Components
Share
February 21, 2010 5:21:51 PM

The power button on the front of my case wont work. I have to always turn on the system by pressing the power button in the motherboard. I need to know what the heck Im doing wrong, so I can get this power button on the front of my case to work. Here is my build.


Azza solano 1000 case
AZZA 850w Dynamo PSU
Msi pro-e motherboard
6 gigs of GSKILL ddr3 1600 mhz ram
Intel I7 920 @ 2.66 ghz (preparing to overclock, applied thermal paste as well)
Corsair H50 cooling system
An older video card from my other system (until I can get a new one soon)
500 gb hard drive
Cd/dvd burner drive

Does anyone have the same motherboard and case? Just really need help.
a c 248 ) Power supply
February 21, 2010 5:59:16 PM

Do you have the power cables for the case power switch installed in the correct location on the motherboard?
m
0
l
February 21, 2010 7:51:18 PM

Could I have the wrong pins in the wrong places? I mean the fans work, everything on the computer is working, its just this one spot.
m
0
l
Related resources
a c 144 ) Power supply
February 22, 2010 11:36:29 AM

Yes you could have the pins in the wrong places. Double check the motherboard drawings. Polarity is not important with switches.

On more thing that you can do is to swap the reset switch with the power switch and use the reset switch to try to boot the system.
m
0
l
a c 248 ) Power supply
February 22, 2010 12:06:09 PM

+1 what jsc said. He beat me to it.
m
0
l
March 31, 2013 12:00:12 PM

jsc said:
Yes you could have the pins in the wrong places. Double check the motherboard drawings. Polarity is not important with switches.

On more thing that you can do is to swap the reset switch with the power switch and use the reset switch to try to boot the system.


We were having this exact problem, and the reset/power switch swap gave us the ability to boot using the reset button. Since my son said he didn't think the reset button was working before and thus never used it, there is no loss, and we are good to go! Thanks jsc!
m
0
l
May 21, 2013 11:25:50 PM

I like the solution but my xpredator x3 case doesn't appear to have a reset button at all!
m
0
l
!