Sign in with
Sign up | Sign in
Your question

CPU/GPU Usage and FPS

Tags:
  • Radeon
  • Graphics
Last response: in Graphics & Displays
Share
December 12, 2009 11:28:58 PM

My system:

P4 Prescott 3.0 Ghz, 800 Mhz FSB
2 GB DDR400, Dual Channel
Abatron Motherboard, 800 Mhz FSB
AGP 8x
450 Watt PSU
Radeon HD 3850 AGP, 512 MB

I'm toying around with different catalyst drivers, from 8.1 to 9.11, but apart from a few failed installs and crashes, they all seem to perform generally the same. I use Driver Cleaner and Driver Sweeper in between each reinstall.

I'm playing Left 4 Dead at 1920x1080, all settings on high. My framerate hovers around 30FPS, in small spaces it jumps up to 45, in large areas it dips to about 20.

My pagefile usage gets to 1GB when the game is running. Normally it's at anywhere between 200 and 300. My CPU usage hovers around 65%. My GPU hovers around 40%. Neither one of them ever reaches 100%, even when the FPS drops. Why am I getting low FPS if my computer isn't being pushed to its full potential?

More about : cpu gpu usage fps

December 13, 2009 3:03:23 AM

Yes, your computer is just at it's limit point....

First, P4 is an old tech, u can't depend much on that....
Second, You only have DDR memory, it's slower than DDR2.
Third, u have an AGP card and
Forth, u play at 1920x1080 and use HIGH setting.

What do u expect?
To me, it's all normal for your system.

Anyone have different idea?
m
0
l
December 13, 2009 3:26:07 AM

I did two things. First, I switched from using the 8.9 drivers to the 9.10 ones. Second, I disabled hyperthreading in the BIOS.

Now the system shows CPU usage at a constant 100%, and GPU usage hovers around 90%.

All in all, you're probably right. I guess I have a system at the end of its life span, and the 3850 is squeezing the last few drops of blood out of it.
m
0
l
Related resources
December 13, 2009 3:32:42 AM

U shouldn't have to disable HT in BIOS...
That's what caused your CPU $ GPU usage jump to 90%+
Try to lowering your resolutions and change the setting to MEDIUM, see if that help...
m
0
l
December 13, 2009 11:38:27 AM

PROBLEM SOLVED! (Mostly)

My framerates aren't a rock-solid 60fps, but the dips I'm experiencing are minor now. What's more, I had also been experiencing stuttering issues at very specific points in the game that are no longer troubling me.

I think I'm lucky that I have a motherboard with a system bus that runs at 200Mhz.

I was running XP from an IDE drive, and the game files from a drive on IDE2. Naturally, both PATA. I was using my SATA drives for the pagefile.

I did a few things:

First, I reenabled hyperthreading and performed a clean install of XP on a SATA drive. Not the old 150MB/s style, one of the newer 300's. (Remember to take off that bandwidth limiting jumper, kids!)

Second, I DISABLED virtual memory.

Third, I remembered a couple of old XP tweaks that I'd forgotten about, most of which were taken care of by a memory manager called Cacheman. Tweakguides.net has the skinny on all the correct settings for it.

Third, I moved my Steam game files to my second SATA drive. I installed the Catalyst 9.10 drivers (minus the CCC, although I don't know yet if installing the Control Center will slow me back down at all) and WHAMMO. Fired up L4D and everything runs like a charm. I have the settings all on high (very high for shader quality), running at full resolution 1920x1080 with 8xAA and 16xAF.

I'm no longer getting major FPS drops, even when the zombie mobs come out of the woodwork.

My system may be on its last legs, but it's still standing!
m
0
l
December 13, 2009 11:41:46 AM

Oh, and I forgot to mention that I made sure to defrag everything with Diskkeeper. Happy trails!
m
0
l
December 13, 2009 12:59:53 PM

Okay, u did a lots to make your computer ALL OUT...
Nice.. Congratulation... :) 

And thanks for the info man, it's really wonderful...
m
0
l
!