Sign in with
Sign up | Sign in
Your question

BIOS only recognizes 4gb, but CPU-Z sees 6gb

Last response: in Memory
Share
June 28, 2010 6:24:39 PM

I have 6gb of G.Skill ripjaw DDR3-1600 installed into my Asus rampage gene II mobo (and an i7 920). My BIOS says it only recognizes 4gb but if I fire up CPU-Z it says 6144 Mbytes of DDR3 in Dual Channel. I checked my CPU for bent pins earlier when I was having booting issues and am out of thermal paste so I really don't want to have to take that off and check again, is there any other options i can try? (I am running windows 7 proffesional and I did make sure the max memory was unchecked in msconfig)

Thanks
a c 163 } Memory
a c 158 à CPUs
June 29, 2010 4:25:54 AM

Do u check the same "max memory" in the BIOS too?
June 30, 2010 2:15:28 AM

I'm not sure how to do that...
Related resources
a b } Memory
a b à CPUs
June 30, 2010 4:09:11 AM

Try 1 stick at a time, see if it is a faulty ram stick. If all 3 sticks work.. then it's Asus. If it is the Asus board, then try to update the bios. If it is still glitching if it IS the asus board, then send the board back and get a new one, or just live with it. Asus has some boards that have a kind of "short" in them about reading all the ram... I know this because I have one. Every other reboot it only reads 10 of the 12gb's I have. Researched it, and it's common.
a b } Memory
a b à CPUs
June 30, 2010 4:11:02 AM

By the way, even though CPU-Z reads it and Bios doesnt, thats because bios counts the ram. CPU-Z only reads the information on the ram. It's common
June 30, 2010 3:24:20 PM

Got it to work! not sure 100% what I did to make it work, just tried the sticks in a different order and it read 6gb. One of them may have not been seated properly I'm guessing (although I've tried that before) But if it works it works, and I'm happy

Thanks guys.
a c 163 } Memory
a c 158 à CPUs
June 30, 2010 3:33:35 PM

Well good news for u. Now enjoy ur rig. ;) 
!