Sign in with
Sign up | Sign in
Your question

Only 4gb of Memory recognized out of 6 installed?

Tags:
Last response: in Memory
Share
Anonymous
a b } Memory
July 1, 2010 3:36:48 PM

Specs:
Asus P6X58D Premium
i7 920
6gb corsair xms3 DDR3(3x 2gb 1600)

I initially installed the Ram and only 4gb showed up, so I powered off unplugged everything and removed RAM. Reinstalled all 3 sticks plugged in rebooted and 6gb showed up. Thought maybe wasn't seated right and that was problem, everything running fine but noticed when restarted computer WIN 7 64 only showing 4gb!?
Does anybody have an idea here? I am trying to figure out if it's my Mobo or the Memory? I don't know which I need to RMA or if I even need to. Could there be some sort of setting I am missing to make it recognize the 6gb?
I don't have another Mobo to test this RAM in either. Just strange that it showed up after reinstalling and then 2gb of it just seemed to go away after restarting my comp. PLEASE HELP!!! Don't know if this helps but the memory model is (TRX3X6G1600C8 G) Just trying to figure this out before my RMA service is up at newegg! Thank you for any and all help! This forum has saved my a** in the past counting on you guys/gals coming through for me yet again!!!
a c 163 } Memory
July 2, 2010 1:51:00 PM

Hi newcomer and welcome to the Tom's hardwareforum.

Run msconfig, boot.ini tab, advance option and check that the /MAXMEM option isn't selected.
a b } Memory
July 2, 2010 4:10:37 PM

Test this:
Reboot a few times without completely powering off. Then reboot a few times completely powering off. Maybe 20 reboots all together. Check to see how much CPU-Z shows and how much Windows shows each time. It's a known issue that some Asus boards have a kind of short in them that sometimes it reads all ram, and sometimes it doesn't. If that's the case then you can do a Bios update (may not fix) or RMA the board
Related resources
January 2, 2011 3:34:16 PM

This is a known problem with all 1366 boards, I've seen people having problems on MSI, Gigabyte, and ASUS- probably others too.
My Rampage III Formula wouldn't recognize all my triple-channel RAM. I had 2 systems, one with 6GB and one with 12, they showed 4gb and 8gb in BIOS and in Windows. The RAM was all Corsair DDR3-1600, model# CMX6GX3M3c1600C7, 2G x3. Both CPUs were i7-960s at stock, both systems with dual EVGA GTX460's in SLI.

I solved it by the following procedure (it's time consuming, but it worked):
1- Clear CMOS and save BIOS defaults on reboot. (not sure this was needed, see step #2)
2- Use the Q-Reset button on motherboard, this resets the CPU w/power down; same as pulling the CPU out of the socket. It's supposed to reset something on the CPU, or maybe in the RAM controller which is built into the 1366 CPUs. This made me re-save the BIOS defaults again, must be the CPU reset also resets the CMOS/BIOS settings.
3- Add one DIMM, go into BIOS, check that RAM shows, save settings. Then go into Windows, make sure it sees all the RAM.
4- Reboot, rinse, repeat.

After I did this for 3 DIMMS on one system and 6 DIMMs on the other, all of it showed up in both BIOS and Windows. CPU-Z shows all RAM in correct slots, and shows it as Triple channel. When Windows wouldn't see it previously, CPU-Z showed the RAM as Dual channel, although it could see all 6gb and it could tell it was in 3 slots.

After all the RAM was recognized, I went into BIOS and changed from DDR-1066 (default) to 1333, reboot and verified it showed in BIOS and Windows, then went from 1333 to 1600. The ASUS board offered to automatically set the DIMMs to the correct voltage for 1600, which is 1.65. It works, I have not yet tweaked the timings to 7-8-7-20 which the RAM supports.

Maybe this process will help some other boards recognize all their installed RAM. I think it's a problem with the X58 detecting the RAM as triple channel, but I have no idea why. Maybe Intel will come out with an update, but I'm not holding my breath.
a c 347 } Memory
January 2, 2011 3:43:32 PM

This is a dead thread

BIOS 80% -> incorrect DRAM Voltage and or QPI/DRAM Voltage settings. The other remaining issues are: bad/incompatible sticks or DIMM Slot. There are other oddball issues including partitions with 32-bit OS, and more. Each situation is different.

The P55 is the king of the hill for 'missing' RAM.
!