Sign in with
Sign up | Sign in
Your question

[PLEASE HELP ME ASAP] eSATA with EX38-DS4 on Windows XP SP3

Last response: in Motherboards
Share
July 1, 2010 4:09:35 PM

Hi Everyone,
So I have a gigabyte EX38-DS4 motherboard on a custom-built Desktop PC with Windows XP SP3. The situation is that I have the eSATA bracket that came with it connected to the motherboard and I want to use an external hard drive which I have built on the eSATA bracket. Everytime I plug it in, I can browse through files and the folders fine. However, when I try to get files onto the external hard drive or take files off of it, then, the transfer speed slows down until my system freezes and I have to reboot.

Please note that I do not want to have to reinstall windows or change out my motherboard.

I have spoken to gigabyte but they were not able to replicate the problem.

Does anyone know what the problem could be. Please answer me as soon as possible.

OS: Windows XP SP3
RAM: 3GB DDR2 Memory
HDD: 250GB SATA HDD and an 80GB SATA HDD
DVD: SATA DVDRW with dual layer support
Motherboard BIOS version: F5

Hope to hear from someone soon,
Adiman423

a c 177 V Motherboard
July 1, 2010 4:27:48 PM

Where is the external drive getting its power from? If you're not using the connector in the center of the bracket, hooked up to your PSU, you might be getting 'ground-level' grief...

I 'sliced up' my bracket to get the power connector free, and mounted it in a front panel:

(toward the bottom, right of center...)
as I have a front panel eSATA built into the case, but had trouble with 'enclosure-supplied' power for externals - went away when I started using the PSU power... And, if I remember correctly, the drive would work when plugged in, just 'accumulate' so many errors, it couldn't continue to try to work!
July 1, 2010 5:15:40 PM

I can tell you that I am powering the external eSATA enclosure using a USB 2.0 cable. On the other hand, here are the other options I have not considered yet.

1) using a PCI express eSATA controller
2) disconnecting all the wires from the back of my PC. Then plugging each one in to see what is causing the problem.

I should also mention that the laptop hard drive itself is SATA I and the motherboard's SATA ports as you may already know are SATAII
Related resources
a c 177 V Motherboard
July 1, 2010 6:51:32 PM

I'd suspect the USB power... Do you have/can you plug it into a powered hub? Is it a big deal to remove from the enclosure? (mine is about ninety seconds - six screws and a 'tug', and she's out!) I don't think SATAI should be trouble - everything is 'backward compatible'...
July 1, 2010 8:35:01 PM

I took the hard drive out of the enclosure. It's a 320GB Laptop Hard Drive and it sees it with no problems. I can transfer files just fine.
a c 177 V Motherboard
July 1, 2010 9:39:35 PM

Excellent! My guess - power; see if you can borrow a powered hub to try it out - may fix the whole problem and not require cracking the enclosure...
July 3, 2010 4:28:35 PM

I have tried a powered hub and still no joy. Maybe I might need to use a different enclosure or surely I must be missing a trick
a c 177 V Motherboard
July 4, 2010 2:37:33 PM

I don't know what else to try - I've run out of ideas... Obviously, it has to do with the enclosure: drive + enclosure = failure; drive - enclosure = works fine! What I can't figure out is 'why'? (Which, by the way, I consider my usual forte - figuring out 'why'!) I believe the problems I've seen with my equipment stem from 'ground level' issues. 'Ground' is a very important thing to computers, as they have myriad signals on a huge number of 'busses' (memory, PCIe, USB, PCI, DMI, LPCIO, and on, and on...) whose 'means of detection' is always 'comparison' to ground - if the ground on any one of these is 'level shifted' (i.e., not at 'true' ground, Vss - 0V), its 'detection' circuitry becomes 'iffy', and likely to exhibit sporadic, or complete, failures... Now, with a USB-powered enclosure, the ground must be 'served up' by the USB hub on the board - which, by definition, is at 'board ground' - leading to my theory that insufficient power pretty much 'was left' as the likely culprit... If a powered hub didn't cure it, I'm left with no theory at all! Doesn't mean I'll quit 'puzzling about it', though - just that a solution (from me, anyhow!) may not be 'quickly forthcoming' [:isamuelson:8]
a c 177 V Motherboard
July 4, 2010 2:47:06 PM

Hey - dammit - writing this made me think of something! Long-shot, though... Did you happen to use insulating washers when you installed your board on the stand-offs? Most common cause of 'ground failures' in modern systems... For a long time, cant even remeber what decades, you had to install the insulators under your screws - then, the boards 'switched over' to 'distributing' case ground via the screws - and the insulating washers became a no-no!

People who 'roll their own' tend to get a lot longer life 'between builds', so this issue often catches 'old-timers' (like me [:bilbat:6] ), who haven't done a build for a goodly while...
July 5, 2010 2:14:35 AM

Which SATA port are you using? Is it from Intel ICH or Gigabyte SATA?
What is the controller type you set in the BIOS?

AHCI = should be no problem to plug your eSATA drive when OS has loaded.
IDE = try attaching your eSATA drive to the system before you switching on the power.
July 5, 2010 10:13:09 PM

I bring you all good news. So I managed to get hold of a different enclosure that was not the same brand as the one I was using. I put the hard drive inside the new enclosure, connected it to my PC and turned on the PC. I booted into windows and it works.

The only downside is that I have to shut down the PC and connect it in every time I wish to use it. However, that is a problem I will have to live with. Thanks for your help everyone.
July 6, 2010 2:24:38 AM

AHCI supports hot plugging~ you may consider to switch it over when next time you re-install your OS.
!