Sign in with
Sign up | Sign in
Your question

ATI 5770: How to force 3D clocks?

Last response: in Graphics & Displays
Share
December 15, 2009 12:47:22 AM

Hi, my ATI 5770 won't clcok itsefl at stock settings (850/1200) while playing FIFA 10, PES 2010 or Guitar Hero 3; but rather throttle back and forth from 2D to 3D (max) clocks, causing severe stuttering in those games.
Is there any way I can force stock clocks or disable throttling?

More about : ati 5770 force clocks

December 15, 2009 1:20:26 AM

I just found the following info in this thread:
http://forums.amd.com/game/messageview.cfm?catid=260&th...

Quote:
Steps:

1. Open CCC

2. Unlock and Enable Overdrive if they aren’t already.

3. Go to Options/Profiles/Profiles Manager. Create a new profile. Under composition make sure “ATI Overdrive” is checked. Save and Close, DO NOT ACTIVATE.

4. In windows go to: C:\Users\{yourusername}\AppData\Local\ATI\ACE\Profiles (you will need to have “show hidden files” turned on for this)

5. Open the xml document with the name of the profile you just created (notepad is fine)

6. Change the values of the Clock and Memory speeds to look like this (these specific values are what worked for me and my card, use judgment) EDIT ONLY THE BOLD VALUES.



Feature name="CoreClockTarget_0"

Property name="Want_0" value="40000"

Property name="Want_1" value="60000"

Property name="Want_2" value="85000"

Feature

Feature name="MemoryClockTarget_0"

Property name="Want_0" value="90000"

Property name="Want_1" value="90000"

Property name="Want_2" value="120000"



7. Save and close. Go back to CCC and activate the profile you just created.

This will make the card idle at 400core, 900memory. (2D clocks are the "Want_0" values)


Soooo,
I did that, but I found other values in the XML file:

Quote:
<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="15700" />
<Property name="Want_1" value="60000" />
<Property name="Want_2" value="85000" />
</Feature>
<Feature name="MemoryClockTarget_0">
<Property name="Want_0" value="30000" />
<Property name="Want_1" value="120000" />
<Property name="Want_2" value="120000" />
</Feature>
<Feature name="CoreVoltageTarget_0">
<Property name="Want_0" value="950" />
<Property name="Want_1" value="1000" />
<Property name="Want_2" value="1125" />
</Feature>
<Feature name="MemoryVoltageTarget_0">
<Property name="Want_0" value="0" />
<Property name="Want_1" value="0" />
<Property name="Want_2" value="0" />


I gather that:
Want_0 = 2D
Want_1 = Mild 3D
Want_2 = Full 3D

Now, If I were to change Want_0 core and memory settings to higher settings, wouldn't I also need to increase the Want_0 value for "corevoltagetarget" too?
I don't want to mess around with this settings, but I think this is the only way....

Should I try it? Are ther any potential risks?
m
0
l
a b U Graphics card
December 15, 2009 6:54:17 AM

You probably don't want to change the voltages. Those are probably the 3 choices 0.95v to 1.125v that the card can do, probably defaulted to the lowest. It shouldn't switch up when moving to 3d from 2d...but don't quote me on that one.

I'd leave that at 0.95v unless you have good cooling and want to overclock it.
m
0
l
Related resources
a b U Graphics card
December 15, 2009 6:55:53 AM

Also check out the ATI gpu tool and see if you can change the voltages/clocks etc without anything untoward happening.

http://www.techpowerup.com/?30555
m
0
l
December 15, 2009 2:38:39 PM

jennyh, what I want to do is to make 2D settings (157/300) be the same as the 3D settings (850/1200) so that the card does not underclock under 2D mode.
To achieve this, I would have to set Want_0 (2D settings) and Want_1 (low 3D settings) at 850/1200 too.
Now, according to the values in the XML file, the core voltage also gets lower when the card underclocks (950 from 1125 in Want_0); but if I override Want_0 core clocks and manually set them to 850mhz; then I think I would need Want_0 voltage to be 1125 (which is the one set for 3D mode 850/1200).
Note: I AM NOT WILLING TO OVERCLOCK THE CARD; JUST PREVENT THROTTLING.

What puzzles me is that I entered the following values:

<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="85000" />
<Property name="Want_1" value="85000" />
<Property name="Want_2" value="85000" />
</Feature>
<Feature name="MemoryClockTarget_0">
<Property name="Want_0" value="120000" />
<Property name="Want_1" value="120000" />
<Property name="Want_2" value="120000" />
</Feature>
<Feature name="CoreVoltageTarget_0">
<Property name="Want_0" value="1125" />
<Property name="Want_1" value="1125" />
<Property name="Want_2" value="1125" />
</Feature>
<Feature name="MemoryVoltageTarget_0">
<Property name="Want_0" value="0" />
<Property name="Want_1" value="0" />
<Property name="Want_2" value="0" />

And the PC crashed with a blue screen (not windows' BSOD but a plain blue screen).

Isn't there any other way to disable powerplay?
m
0
l
a b U Graphics card
December 15, 2009 2:44:23 PM

Tbh if your card is throttling it's a heat issue that is better off being fixed instead of messing around with the card settings.

I'm not sure about all that stuff you typed but I know you can rewrite the bios on any card...check around for a utility that lets you do that.
m
0
l
a c 84 U Graphics card
December 15, 2009 2:49:19 PM

and you are sure the throttling and stuttering doesn't happen because of cpu bottlenecking? if the card is waiting some stuff it's likely it will downclock itself...
m
0
l
December 15, 2009 3:00:44 PM

Jennyh,
the card never goes past 70º while in crysis or under torture tests... so temperature is NOT the problem.
The problem is FIFA 10 and other games use just about 5% of the GPU; and thus the card does not reach its default clocks (850/1200); like it does in other games such as Modern Warfare 2; Crysis, etc.
m
0
l
December 15, 2009 3:33:10 PM

THX jennyh,
I think I'll try some other workaround, I'm not comfortable with BIOS tweaks, and the card is just too new to screw it up lol.
m
0
l
!