Closed Solved

What SATA Mode Should My Motherboard Be In?

I've read a lot of posts about SSDs having to be in AHCI mode, right now my HDDs are SATA but in the BIOS they're in IDE mode... is this correct? What's the difference?
10 answers Last reply Best Answer
More about what sata mode motherboard
  1. AHCI mode allows advanced features of the drive to be used such as hot-swap, NCQ (native command queuing), and in the case of SSD's, the TRIM function.

    Vista and 7 have native sata drivers (AHCI). XP doesn't thus needs them installed during windows installation. Win 7 can be changed after the fact.

    http://support.microsoft.com/kb/922976
  2. So, with standard HDD (don't have any SSDs yet), I can just leave the settings be for now? Or, because I have the option to put it in AHCI mode, should I just have that turned on? If I turn that on, would that require a fresh install or would it affect anything?
  3. Ummm.... you never mentioned which OS you have so I can't answer accurately other than to tell you to re-read my last post, especially the 2nd paragraph + included link.
  4. I'm running Win7 x64, the mode is available... what I'm asking is, should standard SATA HDDs be running under that option, and if yes, would it do any harm to switch to it?
  5. You will get a slight performance boost in AHCI. Yes, sata drives should be set to AHCI by default unless you are running XP. The performance gain isn't worth the hassle of installing drivers for XP.

    No, it won't harm anything to switch it. You just need to follow the directions in the link I posted earlier. If you don't make the necessary registry changes, windows will blue screen when you boot up.
  6. So I followed the link, downloaded the wizard, ran it, restarted, went into the BIOS, switched to AHCI, and now my computer keeps looping into Windows Startup Repair. After it finishes, I restart, and it goes through boot, shows "Loading Windows Files..." along the bottom, shows the Windows startup logo, then goes into Windows Startup Repair again. Repeat... etc.


    What the heck do I do now? Sorry, panicking.
  7. Best answer
    Just switch the bios back to IDE. That should stop the rebooting. If not, boot into safe mode and set the registry entry back to what it was before. If you don't remember what it was, do a system restore to yesterday. I've used this method before and know it works. Did you use the fixit or manual instructions? I'd use the manual instructions.

    To resolve this issue yourself, enable the AHCI driver in the registry before you change the SATA mode of the boot drive. To do this, follow these steps:

    Exit all Windows-based programs.
    Click Start, type regedit in the Start Search box, and then press ENTER.
    If you receive the User Account Control dialog box, click Continue.
    Locate and then click one of the following registry subkeys:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
    In the right pane, right-click Start in the Name column, and then click Modify.
    In the Value data box, type 0, and then click OK.
    On the File menu, click Exit to close Registry Editor.
  8. OK, after some restoring and registry editing... I'm back in business. I don't know why it was such a hassle and Windows was being so difficult, but thank you for all your help. I hate when my computer goes into a loop, it makes me feel so helpless. All is well, my mobo is in AHCI mode and everything seems to be back to Situation Normal again. thanks!
  9. Best answer selected by DeeJayBoS.
  10. Awesome! Glad you got it working. :)
Ask a new question

Read More

Hard Drives SATA Motherboards SSD Storage