Sign in with
Sign up | Sign in
Your question

Issues with XFX Radeon 5850 (Crashing)

Last response: in Graphics & Displays
Share
December 15, 2009 5:04:32 PM

Hello everyone,

This is my first time posting on these forums, but I wanted to turn to the community who might have more experience with this issue to resolve it.

I recently put together a new gaming rig and I've installed three games: Modern Warfare 2, Splinter Cell Double Agent, and Mass Effect. So far, I've been getting a variety of issues with crashes and such.

Here are the crash logs for MW2 and SCDA:

Problem signature:
Problem Event Name: APPCRASH
Application Name: SplinterCell4.exe
Application Version: 0.0.0.0
Application Timestamp: 4539e082
Fault Module Name: StackHash_5b15
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 09ff5d28
OS Version: 6.1.7600.2.0.0.256.48
Locale ID: 1033
Additional Information 1: 5b15
Additional Information 2: 5b15e94424fa72ed9efbe16f4814d34f
Additional Information 3: d92c
Additional Information 4: d92c3728204e92aaba441e69d93001af

Problem signature:
Problem Event Name: APPCRASH
Application Name: iw4sp.exe
Application Version: 0.0.0.0
Application Timestamp: 4b16d184
Fault Module Name: d3d9.dll
Fault Module Version: 6.1.7600.16385
Fault Module Timestamp: 4a5bd9a9
Exception Code: c0000005
Exception Offset: 00025aa7
OS Version: 6.1.7600.2.0.0.256.48
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

These two errors happened within 30 seconds of starting up the actual gameplay (menu screens worked fine).

In addition, I've also had similar crashes to those in the link: http://windows7forums.com/windows-7-support/28424-getti...

I'm not really sure what to make of it, but could it be related to hardware compatibility, power supply issues, or just ATI's drivers still being buggy with DX11? The computer works fine when I'm doing mundane everyday stuff (checking e-mail, browsing the Internet, etc.)

Any help would be appreciated. Thank you in advance.

Here are my system specifications:
Asus P7P55D
Intel Core i5-750 2.66GHz
G.Skill Ripjaws 4GB DDR3 1600
XFX Radeon 5850
Corsair CMPSU-750TX
Western Digital Velociraptor 300GB
December 25, 2009 12:00:25 PM

Whenever 3d video stops working you to make sure you are running a stable system. Almost all video card issues are hardware (power, heat, overclock or driver) related. Especially if it crashes right away.

I have 2 x 5850's in Xfire and there are zero issues. Its not the driver - its your hardware.

Our goal is to get 3D to work then you can ramp the system up.
Start at the beginning - make sure your BIOS is set correctly and you are using DEFAULTS. Slow down your RAM for the time being. NO overclocks anywhere. Check everything. Set the RAM timings slower than default - check their voltage - ITs either 1.65 or 2.2 (I forget what I5's want)

Test

Look at the power supply - make sure you are using different power feed lines from the supply.
Most mb's need an aux power connector for PCI cards and the 5850 needs 2 additional power feeds.

If all is good I would start by testing your RAM with memtest

Look at the CPU - 3d mode kicks them all into a higher voltage and temperature state. 2d does not stress at all. Voltage and fan all good?

Lets see where that gets you
m
0
l
a c 105 U Graphics card
December 25, 2009 2:59:18 PM

I don't see opsys listed.. W7...? perhaps a glitch there....W7 does have it's problems......... I have some Ripjaws memory. I can't get it to run where it's "supposed" to in different configurations. Did you try running it slower ? I also have a 5850 and get some black blotches In different games from time to time. FarCry2 is one of them. Immature drivers ?? Bad card ? Thought I'd hang on t0 it for a while and see if problems clear up ( new drivers ) before I RMA it.
m
0
l
!