Sign in with
Sign up | Sign in
Your question

ATI Radeon 4850 HD Lag problem

Last response: in Graphics & Displays
Share
December 16, 2009 1:17:54 AM

I noticed this issue since i play Left 4 dead 2, im so happy with this card really it runs anything on 1920x1080 maxed out without any kind of problems, anyway, while i play either l4d2 or cod mw2 sometimes it slows down for a bit and suddenly it gets back up working just fine so its more like random it seems, it runs nice with the dust, smoke, fire and when there's nothing it slows down and gets back up when it shold slow down (fire, explosions etc) I've tried reinstalling drivers, deleted old ones and reinstaleld latest CCC, i dont know what to do i've tried lowering settings on these games and i get the same problem so its got to be something else, probly a hotfix out there? tweak? thanks system specs: Windows vista ultimate 64bits Athlon II x2 3.0mhz 4 GB ram Ati Radeon 4850 HD
December 16, 2009 1:31:35 AM

okay, what version of 4850? 512MB or 1GB?
If u have 512MB and playing at 1920x1080 then it's possible like you said above.
Also make sure there's no antivirus scanning on the background or anything run when u playing...
Vertical sync is on?
Try to turn it off...
m
0
l
December 16, 2009 6:13:10 AM

its actually random, i noticed that using alt+tab and then maximizing the game back up fixes it, but its obviously not a fix.. any ideas whats going on?
and yes i have the 512 cus it runs much faster than the 1gb one
m
0
l
Related resources
December 16, 2009 8:06:47 PM

that's odd considering i play gta 4 maxed out, even saints row 2 another poorly optimized game brought to the pc, as i said i have to alt+tab and the maximize the game again so the slowdown disappears, any other ideas?
m
0
l
December 16, 2009 10:39:49 PM

wa1 u nailed it, i just lowered the vertical sync on my CCC now its running beautifully at 1920 x 1080 maxed out! apparently they told me if u lose one frame or something like that the whole thing slows down trying to synchronize the whole thing, now its working awesome, thanks!
m
0
l
December 17, 2009 1:46:32 AM

Yes, i know it's hard to believe too, cause 4850 is not optimize at 1680x1050 above...
I have 4850 too, i choose it cause my monitor is just 1280x1024 max... :) 
m
0
l
January 15, 2010 3:37:07 PM

I havent played Left 4 Dead, but notice a similar problem with my 4850 on Jade Dinasty. But in my case is not random, it happended on specific places on town. Everytime I walk to those "spots" the frame rate goes down drastically.

Havent notice the problem in Wow. So I guess is engine related.

FYI I Have a VisionTek 4850 512MB, Catalyst 9.12
m
0
l
!