I am in duel channle memory mode and i cant press f2 or f11

hi i am having a problem with my computer when ever i turn it on it brings me to dual-channel memory mode

it tells me to press f2 to run setup or f11 for boot menu but when i press them they don't work i have

tried 3

different keyboards but still the same problem the way this happend was i was cleaning out my computer

i moved it around the house for a good spot then i set it all up and it put me to this screen and i cant do

anything to get out of it here is some info on my computer


amibios (c) 2004 american megatrends , inc.

4coredual -vsta bios p1 .50

cpu: intel (r) pentium (r) dual cpu e2200 @ 2.20ghz

speed : 2.20 ghz


so it basically give's me all that info then it says run setup f2 and boot menu f11 then under that it says

dual channel memory mode 2048mb ok: i have tried everything i think it might have something to do with

my graphics card i tired to take it in and out but still i get this screen so if anyone can help me that would

be awesome tks
1 answer Last reply
More about duel channle memory mode press
  1. Re-seat the memory, if that doesn't work reset the BIOS to factory defaults. Couple things to try at least.
Ask a new question

Read More

Memory Dual Channel Computer