Gigabyte Motherboard not working

I have a computer that I just built. When I power it on though, the keyboard I have plugged in, the lights come on(caps lock num lock scroll lock) for about a second while the screen is black, and then go off. Then the Gigabyte Logo Screen loads and it appears as if the keyboard is not connected since the lights have gone off and I cannot select any of the choices.

If it helps here is what I am using:
GIGABYTE GA-EP45-UD3P LGA 775 Intel P45 ATX Intel Motherboard
Intel Core 2 Quad Q8200 2.33GHz 4MB L2 Cache LGA 775 95W Quad-Core Processor
WD Caviar 500GB Serial ATA HD 7200/16MB/SATA-3G
XFX Radeon HD 4670 1GB PCIe w/Dual Link DVI
5 answers Last reply
More about gigabyte motherboard working
  1. What kind of keyboard? If USB, have you tried a PS2 keyboard?

    Does it successfully complete the POST (single short beep)?

    And our standard checklist and troubleshooting thread:
    http://www.tomshardware.com/forum/261145-31-read-posting-boot-problems
  2. I tried both a USB and a PS2. Im not sure if the USB worked or not but the PS2 was the one that blinks. And I have no idea what you mean about POST
  3. DID YOUY TRY CLEARING THE CMOS WITH THE JUMPER ON THE MOTHERBOARD
    SHOULD NE IN YOUR manual also when you do make sure you turn off or unplug your power supply
  4. Is the sata connector correctly plugged into your motherboard?
  5. I tried clearing my CMOS, but only by removing the battery. In the manual is says to use a screwdriver and touch it to it for a few seconds. Im assuming it means both pins?

    And what SATA connector? Im trying to plug it in to the back that is attached to the MB.
Ask a new question

Read More

New Build Gigabyte Systems