Sign in with
Sign up | Sign in
Your question

Default Folder Open Location/Size

Last response: in Windows XP
Share
July 2, 2012 7:03:36 PM

I haven't been able to return any useful results with my own searches so I turn to you. (Maybe I'm wording it wrong.)

I work on a two moniter setup. When i create a new folder on my desktop and then open it, it defaults to being displayed on my right (secondary) moniter. Is there a way to make new folders open on my primary monitor every time? What about the default size of the folder once it's opened?

Thanks!
July 5, 2012 5:48:40 PM

I use a 2 monitor setup as well. anything that i save to the "desktop on the second monitor will open on the second monitor, likewise if I save it to the desktop on the primary, it opens in the primary unless I drag it over to the secondary.
As for default size, do you mean the size of the window once the folder is opened?
m
0
l
May 9, 2013 10:33:21 PM

I had this exact same problem, and it was annoying the fuff out of me! But I solved it by doing the following:

First of all, I have these Explorer Folder Options settings checked (Tools > Folder Options > Views):
* Launch folder windows in a separate process
* Remember each folder's view settings.

In Regedit, navigate to and export/backup the following keys:

HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\BagMRU
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags
HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\BagMRU
HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\Bags


once they're safely exported, delete them. This will reset all of File Explorer's saved folder views.

Then go to Control Panel > Display > Settings. Click on your second monitor and then turn off "Extend my desktop onto this monitor." Click OK or Apply.

Then open a folder from your desktop. It should open up in the middle of your primary monitor. Now close the window you just opened.

Go back to Control Panel > Display > Settings. Now turn back on "Extend my desktop onto this monitor." Click OK or Apply.

Now (if you're lucky and the Gods are smiling upon you), folders should no longer open all the way over on the right side of your second monitor AND it should also start remembering the size and position since you last closed each folder.

Another trick I've learned is to increase the number of folders view settings Windows remembers from the factory default of 400 to whatever you want (I set mine to 5000). If you have TweakUI, there's an option under Explorer > Customizations called Folders to Remember. Change this to a reasonable number and good luck. And also, do what I did and write down the steps to whatever it is that you did to solve this problem, because I guarantee you that in about 6 to 18 months, Windows will again "forget" your settings and start opening up new folders at the least desirable location on your desktop and you'll have to do these steps all over again.
m
0
l
!