Sign in with
Sign up | Sign in
Your question

Is it possible to use same network on wireless router

Last response: in Wireless Networking
Share
March 13, 2010 7:30:45 AM

I'm having an wireless router for laptops,
currently i have connected one of terminals from my LAN to the WAN port of router for internet sharing..
ip address used in LAN 192.168.1.0/24
ip address used in router for clients 162.168.2.0/24( WAN port receives ip from DHCP which is in 192.168.1.0/24)

my requirement is
is it possible to assign same N/W for WAN & LAN ports in router , bcz we are using ipmsg an intranet messenger with LAN for msg & files sharing, i want it to work on laptops connected to wireless router which is now working in 192.168.2.0/24 N/W ..
(i.e assigning static ip for both WAN & LAN port of router with 162.168.1.0/24 )

in simple i want to use router to work like an switch
Anonymous
March 13, 2010 9:36:51 AM

Change the IP address of the wireless router to be something in the 192.168.2.0 range but outside of the DHCP scope, disable DHCP and connect the network cable to a LAN port and not the WAN port. If you need the WAN port you need 3rd party firmware like DD-WRT.
Related resources
Anonymous
March 13, 2010 11:02:27 AM

Then just reverse it and make the changes to the wired router.
a b X LAN
March 13, 2010 12:47:31 PM

[modem](lan)<--wire-->(wan)[router #1 (192.168.1.1)](lan)<--wire-->(lan)[router #2 (192.168.1.2)]

All clients of both routers have access to each other and the Internet because they all share the same network, they're merely switched. The only routing that takes place is from router #1 to the Internet via its WAN port.

That’s why you don’t use the WAN port of router #2, otherwise those clients WOULD be routed between routers, and hence the need for a different network, clients of router #1 would be denied access to clients of router #2 by its firewall, etc.

The only caveat is that because router #1 and router #2 are on the same network, and you never want more that one DHCP server per network, you need to disable router #2’s DHCP server.
!