Sign in with
Sign up | Sign in
Your question

Seagate Expansion Portable Drive 320gb

Last response: in Storage
Share
November 27, 2011 6:53:33 PM

So I have a Seagate Expansion Portable Drive 320gb for my laptop. It was working fine a few days ago until I got a message saying "USB Device Not Recognized". Now I have already changed cables, tried different Computers and still get the same "USB Device Not Recognized".

I thought it was a bad enclosure, so I bought a Iocell Networks Traveler from Fry's. I put the hard drive in the new enclosure and....nothing. My computer picked it up at first, but after the drivers got installed the drive disappears. Even when I try it with a different computer it doesn't see it. But when I put the drive back in it's original enclosure, it picks it up and gives me "USB Device Not Recognized".

Now when I when hook just the enclosure with no hard drive I get "USB Device Not Recognized". But when hook up the new enclosure the computer does nothing. I don't even see the thing in the device manager.

When the hard drive is in both enclosures they both light up and the hard drive makes random clicking noises then goes to an idle spin.

So I don't know. Do I have a dead drive, bad PCB, or a two bad enclosure?

Hard Drive:
Seagate Momentus 5400.6 320GB
WWN: 5000C5002B935248
SN: 6VD6QEJN
ST9320325AS
PN: PHH13E-567
FW: 0002BSM1

Computers Used:
Toshiba Satellite L305 - Windows Vista Home Premium SP2
HP Presario CQ56 Notebook PC - Windows 7 Home Premium

Enclosures Used:
Original: Seagate Expansion Portable Drive 320GB
P/N: 9SD2A3-500
S/N: 2GH49NC9
New: Iocell Networks Traveler
November 28, 2011 7:33:29 PM

It turns out I have both mad enclosures. I found that out by putting the hard drive directly into the laptop and run mini windows xp. And it saw the drive!

It was a scary but educational experience.
m
0
l
!