Sign in with
Sign up | Sign in
Your question

Laptop cannot connect when MAC filtering enabled

Tags:
  • Configuration
  • Laptops
  • Wireless Router
  • Connection
  • Macintosh
  • Wireless Networking
Last response: in Wireless Networking
Share
March 13, 2010 4:29:08 PM

Hello,
I'm using a 2wire wireless router with MAC filtering enabled.
I'm trying to set up a laptop with an Atheros AR5001X+ card.
When I disable the MAC filtering I can connect, when I enable MAC filtering it won't connect.
I can't use encryption because of the many OS's that attach.
Any thoughts?
Thanks
Don

More about : laptop connect mac filtering enabled

a b D Laptop
March 13, 2010 4:37:30 PM

It almost sounds too silly to ask but someone has to... you did add the MAC address of your Atheros card, right?!
m
0
l
March 13, 2010 4:45:39 PM

Yes, it shows up in my wireless listing of MAC addresses. In this case I disabled the MAC filtering and waited until it was discovered by the 2wire.
Sorry for not mentioning it.
Don
m
0
l
Related resources
a b D Laptop
March 13, 2010 5:02:57 PM

Did you use the correct syntax?

Some MAC filters will require colons (00:fc:64:ef:43:1b), others hyphens (00-fc-64-ef-43-1b), or nothing at all (00fc64ef431b).

And it's configured for Allow, correct?
m
0
l
March 13, 2010 5:21:07 PM

This filter needs the colon between and gives you an example to follow, so I used the colons, and it did accept the address in the list. Then I selected the enable checkbox and hit the update button.
It works 2 ways, where you can just disable the MAC filtering and then after about a minute refresh the console, or enter it manually (I've done both) after which I updated the settings and then selected "enable filtering" without success.
Right now I'm looking at the wireless card settings to find something on MAC filtering because other laptops work.
Thanks
m
0
l
March 20, 2010 2:00:18 PM

Well, after about a week of searching I got the answer. It seems that the 2wire modem (2101HG-B) has a bug, whereas it dosen't release the old MAC address unless the computer name is changed (If that makes sense).
Anyway, I found the answer on another site and when I changed the computer name and did a reinstall, as suggested, it worked.
So the problem is with the modem and I suspect this is true with all of these modems.
Here is the post I found:
Thanks to all and Eric and I hope this helps others!
Don
*************************************************************
Just an update, I did manage to solve this problem. Its a bug (I believe) in the 2Wire router. It kept pulling up the old mac address of the discarded wireless card, even when I entered the new mac address manually. Of course you can't tell this is happening because it replaces the mac address with the computer name. The only way around this problem was by giving the computer a different name, then, the router sees this a new machine and adds the proper mac address to its allow list. Wierd. – Eric Feb 9 at 3:53
m
0
l
a b D Laptop
March 20, 2010 2:22:27 PM

Thanks for the update. I'm sure it will help someone in the future.
m
0
l
May 20, 2010 12:58:17 PM

Yep - it just helped me.

I had the same problem with a wireless network card in a desktop. I switched cards and then found I could only connect if I disabled MAC filtering. I tried adding the MAc address manually but that still didn't work. Changed the (full) name on the PC and that fixed it. Now my network is much more secure again wih MAC filtering ON.

I think this is a common glitch with many wireless client devices.

So thanks guys.
Tony - Essex-UK
m
0
l
August 6, 2013 5:05:50 AM

eibgrad said:
Did you use the correct syntax?

Some MAC filters will require colons (00:fc:64:ef:43:1b), others hyphens (00-fc-64-ef-43-1b), or nothing at all (00fc64ef431b).

And it's configured for Allow, correct?

It's the same for me... MAC Filtering is set to Allow and I even put in the MAC of my laptop.. Syntax doesn't require colons or hyphens.. But the moment I disconnect the LAN, I can't access WLAN... how?
m
0
l
August 17, 2013 2:52:06 PM

This might be a silly suggestion, but make sure you're not accidentally adding your MAC address to a blacklist instead of a whitelist (a blacklist allows any MAC address to connect except the ones given, while a whitelist only allows the MAC addresses given to connect and blocks all else). Most routers will offer a choice between the two when you enable MAC filtering.
m
0
l
!