Sign in with
Sign up | Sign in
Your question

[SOLVED] ASRock A785GXH/128M Won't Post Most Of The Time

Last response: in Motherboards
Share
July 9, 2010 6:06:07 PM

Hi all. First time in forever posting on these forums but I'm a regular reader of Tom's Hardware.

I've been building my own systems for 15 years. Not saying I can't make mistakes. Just saying that I have the requisite knowledge and skills and have built at least 8 fully functional systems in 15 years. Today I've got a problem I can't figure out....

I decided to upgrade my mainboard and CPU to get better performance and more stability as I was having a lot of software crashes recently. So today I installed an ASRock A785GXH/128M board and an Athalon II X3 2.9 GHZ processor. When the system boots up, everything appears to work just fine. I can run applications, games, whatever. All the hardware is recognized. No unusual smells or sounds coming from the case. No problems.

But that's only when the system boots. 80% of the time it won't get past the POST screen. The ONLY times I've been able to get it to post is by starting the machine from a power off condition. If I try a soft reboot or if I push the reset button I can't get past the POST screen. Additionally, I can't even get into the bios if I try. It just sits there saying "entering setup".

System Specs:
Board: Asrock A785GXH/128M
Processor: AMD Athalon II X3 2.9 GHZ 535 Rana
Memory: Corsair DDR2 800 PC6400 matched pair (2x2GB)
PSU: Thermaltake Purepower 500 NP 500W
Video: NVidia 9800 GT PCI Express (onboard video disabled on the mobo....I think)
Sound: Creative Sounblaster X-Fi Xtreme Audio + Onboard VIA HiDef Audio enabled
Hard Drives: (re)drive external 1TB connected via USB + 3 month old Seagate ST3250318AS SATA 250 GB connected to SATA 1

I think that covers it....

My first suspicion is that the SATA drive isn't always being detected as I had that happen once before, so I tried unplugging and re-plugging it and it didn't help. I've gone through your stickied "have you tried" thread and ensured I didn't make any of the mistakes mentioned. ASRock tech support is on holiday until next week, so if anyone can help me figure this out before then it would be appreciated.

To be honest, if the silly thing never booted it would be easier. But since it runs perfectly when it does boot, I'm confused. Could it be some sort of voltage issue? BTW, I'm not trying to overclock or anything. I loaded the bios defaults. I flashed the bios from 1.20 to 1.30. Nothing seems to help.

TIA
July 9, 2010 6:34:52 PM

I can confirm that even when it won't boot, it does detect the SATA drive. That's the last thing it does. It shows that the SATA drive has been detected, then it just sits there.
m
0
l
July 10, 2010 9:49:29 AM

I believe this was solved. It appears that my external USB hard drive was causing the problem. I believe it was because "Legacy USB Support" was enabled in the bios. Once I disabled that everything seems to be working fine.
m
0
l
!