Sign in with
Sign up | Sign in
Your question

USB 2.0 Problem in XP Pro

Last response: in Windows XP
Share
July 6, 2012 5:43:25 PM

Hello,
I recently reinstalled a fresh copy of XP Pro on my old compy but now the 2.0 enhanced USB driver wont work. I can disable it and then my USB devices work, but at the 1.0 speed. Ive tried uninstalling all the USB drivers, rebooting and reinstalling but to no avail. I am hopelessly stuck! Any ideas how to fix? Thanks!!!!

Mike

More about : usb problem pro

July 6, 2012 5:43:34 PM

Hello,
I recently reinstalled a fresh copy of XP Pro on my old compy but now the 2.0 enhanced USB driver wont work. I can disable it and then my USB devices work, but at the 1.0 speed. Ive tried uninstalling all the USB drivers, rebooting and reinstalling but to no avail. I am hopelessly stuck! Any ideas how to fix? Thanks!!!!

Mike
m
0
l
a b \ Driver
July 6, 2012 5:59:53 PM



Sounds like you haven't brought the system up to date including Service Pack 3. I think doing that will make it easier to find the right driver for that USB Controller. There's well over a hundred subsequent updates after the Pack goes in.


m
0
l
Related resources
a b \ Driver
July 6, 2012 7:09:30 PM

You reinstalled the motherboard specific USB drivers?
m
0
l
a b \ Driver
July 8, 2012 1:31:21 AM

This next topics has been merged by Area51reopened
  • USB 2.0 Problem in XP Pro
    m
    0
    l
    July 13, 2012 3:55:37 PM

    Hi, I have installed the recommended drivers that windows finds for me. I also tried downloading them manually and installing them. I have SiS Pci to USB Enhanced drivers loaded and I do have service pack 3. Is there another driver I can use? I'm not sure what else to do. Thanks for the replies!
    m
    0
    l
    !