Closed Solved

Win 7 64-BIT (Home Premium) Not using all ram.

I recently put together a new Desktop so first of all here are the specs:
Motherboard is a ASRock P55 Extreme which should support up to 16 gigs.
Core I7 CPU 860 (2.8 Ghz)
4 GB Corsair 1333 mhz ram (Dual channel)
Ati Radeon 5750 (1gb version)
600 watt corsair PSU.
Problem is with the ram. When I look in the bios it says 2x2048 mb ram sticks setup in dual channel. When I boot up my Win7 64 BIT home premium it says it finds 4gb but only 2 gb is available.

I tried the MSCONFIG thing where you check if max memory is enabled and I also checked BIOS if there was something wrong there. None of those were the case.

Anyone able to help out?
16 answers Last reply Best Answer
More about home premium
  1. Hello and welcome to the forums
    Try re-seating the RAM,if it didn't help then take each module out and test them one by one and check they report the correct size
  2. I've just tried your suggestion.
    Both sticks do come up as the correct size , i've also switched the ram around which unfortunatly - did nothing.
    I'm puzzled as to why windows only says 2 gb is available because even windows found 4gb.
  3. Have you tried updating your BIOS ?
  4. I have not , shall go look into how-to's for that as i'm new to updating BIOS etc. Will report back if that does not fix it.
    Thanks for your suggestion!
  5. Missing ram is a sign of bent cpu socket pins.
  6. Highly doubt I bent my CPU socket pins but shall have a look after trying to flash my Motherboard.

    Edit : tried both options. CPU socket pins are fine , flashing Motherboard did not help either.
  7. Try clearing the CMOS too,and see if it helps
  8. Cleared the CMOS , unfortunatly no change in detecting the RAM.
  9. Sorry for double post : wont let me edit.
    Have gotten several crashes now so as well as blue screens so therefor it has to be hardware failure. Contacting hardware seller to see what they come up with. Thanks to all who tried to help me out. Case closed for now.
  10. Best answer
    I did more search and found out that it may be your motherboard's problem(if none of the solutions work)
  11. update : ran extensive tests for ram etc and it keeps finding 2 gig. Not too sure what to do now. As suggested I think it might be the motherboard but I feel it's due to settings not due to hardware failure or anything. would it help if I bought more ram or not?
  12. No it wouldn't help if you bought more RAM,because if you have 4GB RAM installed on a 64bit OS,it should recognize it without a problem
  13. dude just reinstall your os and update you mobo's bios on orignal version....... ....
    i think you system seems to be shared your Ram somewhere as you exceed up to 4 gb..
    your mobo and other hardware is alright... its only setup or settings problem... also check your mobos setup...
    hope it would helpfull for you....
  14. Thanks for all suggestions. I had it checked by a proffesional service and they found out my motherboard is faulty. It shall be sent back to the factory and fixed. case is closed now.

    Thanks all for trying to help out!
  15. Best answer selected by Kve.
  16. This topic has been closed by Maziar
Ask a new question

Read More

Chipsets RAM Dual Channel Motherboards