MSI 870A-G54 cant flash BIOS

I put together my new build yesterday which is an AMD 955, MSI 870A-G54, ATI 5850, Antec TP-750, 4gb ram

everything went smoothly except when i tried to flash bios it came up with an error on the restart i tried that several time using the msi live update 4 and nothing any other ways to flash the msi boards? also is this board any good or do you recommend another company or board.

Link to board : http://www.newegg.com/Product/Product.aspx?Item=N82E16813130275&cm_re=msi_870a-_-13-130-275-_-Product
6 answers Last reply
More about 870a flash bios
  1. How is the situation now? Does the board still post? Is it still possible to start windows? Why were you flashing the bios in the first place?
  2. It runs everything as normal i think what happened was it reverted back to the original because it did not flash properly. The main reason i was flashing BIOS was to have everything up to date
  3. Ok i tried again and this is what it reads while trying to load

    CMOS checksum bad
    f1 run setup
    f2 load default and continue
  4. bump
  5. In the first place you should NEVER EVER flash a bios as an upgrade. Only if you encounter problems that might be caused by an old bios version.

    The error you get is common, mostly after flashing or removing the cpu, but it should appear only once. Run the setup and set settings to defaults. Save and reboot. Afterwards you might want to return to the bios setup to do some settings.
  6. hi,
    i do have the exact problem but diffrent issue, i updated my bios successfully but when i tried the control center features, there were problems for example the oc genie, i enabled it, it works fine, but when i put it back to defaults and ask me to restart then upon restarting it just goes blank and it stays blank no matter what, i can't even shut it off by just the power button same goes with reset, the only way to shut it off is by cutting the power supply. When I turn on my computer again it just stays blank the only way to reset and make it work again is literaly take of the battery of the mobo so that it will reset. could anyone help on this, you might say i did not configure it inside the bios before using the control center, I also tried that but the result is the same, could anyone help on this problem, i know we have the same problem about this, try using your control center then set your oc genie then turn it back of im sure we'll get the same result, now the problem is how to fix this.
Ask a new question

Read More

Motherboards BIOS Flash Product MSI-Microstar