Sign in with
Sign up | Sign in
Your question

Primary slave hard disk error

Last response: in Storage
Share
December 5, 2011 1:44:39 PM

Hello, I have a situation which I have found to be quite perplexing to me. I have an ASUS computer, it's about 2 years old, it has two hard drives in it and both are ESATA drives. Last night I decided to reformat the system and start fresh. I powered down the system and disconnected my secondary, I guess it's considered a slave drive, and repowered the system up doing a fresh Windows 7 install on my primary drive. All went well until after I completed my Windows 7 install and tried to reconnect my slave or second hard drive. Upon booting I got a "primary slave drive error" and it said press "F1" to continue. I hit "F1" and the system just rebooted. I tried to enter the BIOS to check how the drive was recognized and I could not enter the BIOS. On the POST screen, the BIOS recognized the second drive, but nothing more beyond that. If it stopped there, I'd think the drive was defective, but it didn't.

I made the decision to allow the PC to boot and then connect the data cable to the second or slave drive after the PC completed it's boot up, sort of like hot swapping. Low and behold when I did this, the computer recognized the second drive, installed the drivers, etc. and as long as I don't shut it off, there were no issues with either drive. I could see it in the system properties, storage management, etc. However, the second I have to reboot, I get the same error again.

Now the only jumper on this drive is the 1.5 or 3.0 GB transfer jumper. My primary drive is 3.0 enabled, so I assume the secondary is 3.0 as well. Does anyone have any ideas as to how to fix this or why it may be happening. Thanks in advance.
December 5, 2011 2:50:06 PM

Is this a laptop? Like a G-series that can take two HDDs? Something seems odd here. eSATA is External-SATA, as in natively hot-swappable, external to the PC (laptop or desktop). Try swapping the drives around on the controller.
m
0
l
!