Sign in with
Sign up | Sign in
Your question

Can a faulty PCI-e slot damage a graphics card?

Last response: in Graphics & Displays
Share
December 23, 2009 6:15:54 PM

I recently built a new machine and it is now killing graphics cards.

Here are my specs:
ASUS M4A79XTD EVO
AMD Phenom II X4 955 Black Edition Deneb 3.2GHz
(2) A-DATA 4GB (2 x 2GB) 240-Pin DDR3 1600
Rosewill Green Series RG700-S12 700W
Graphics details to follow.

I put the machine together with an new EVGA GTX 270 bought specifically for the build. Everything went fine and the machine worked beautifully for three days. I then received several BSODs in a row. Reinstalling the graphics drivers did nothing and I quickly got graphics artefacts in the BIOS and in Windows. Moving the card to a known good machine produced the same results. Assuming that I was just unlucky enough to get a faulty card I submitted an RMA to EVGA and installed an EVGA 9800 GT from one of my other machines in the meantime. This card worked in the system for four days before crashing out of a game to desktop to show display artefacts once again in Windows. I left my other box at school so I cannot move this card over right now to see if it has been completely damaged, but I have a bad feeling. I do not want to reboot the machine again with this card just in case I may not have lost it yet.

I do not think my issue is heat. My room is rather cool, about 65 degrees F and my case is well ventilated. The hottest I have seen the card was 70 degrees C which should be fine. I am suspecting either my PSU or possibly my motherboard. I pulled the PSU and tested the 12V rail (there is only one) with a multimeter. While the PSU was running on my table I was getting a steady 12.11V which is within the accepted range for ATX. It seems more likely to me that the cards are being damaged by PSU voltage spikes, but because there is only one 12V rail it also seems likely that other devices should have taken damage the first time and it didn't seem that any were. Also worth noting is that each card was lost in a different house in a different city so the issue is not likely dirty power from the wall.

Whenever I try to troubleshoot my own issues like this one my perception tends to get clouded by the dollar signs that I'm burning through with each lost card. I am looking for outside input. Does it seem likely that the PSU is the cause of the problems? Has anyone heard of a motherboard damaging cards before? Is there some other possibility that I am overlooking?

Thanks in advance for any input.
a c 1363 U Graphics card
December 23, 2009 6:30:42 PM

You certainly have nailed down the two most likely culprits. If the slot is faulty it sure can damage the card. Measuring stable 12.11 volts on the PSU indicates that the board is faulty but then again the voltage on the PSU might change under load.
m
0
l
December 23, 2009 6:46:54 PM

Yes, This is exactly where I'm at. I doubt both are faulty but I cannot think of a way to Isolate the problem without burning out another graphics card. I'm not sure if I can get an RMA on either without more evidence that whichever device is responsible for the problem. Any clever ideas on how I can isolate the problem without loosing more cards?
m
0
l
Related resources
a c 1363 U Graphics card
December 23, 2009 6:51:29 PM

If you bought them from the same vendor contact them. The other thing you can do is if you can find out which pins in the PCIe slot are the power pins you could check what voltage you have there with the multimeter. If it is the same as the PSU delivers it points to the PSU.
m
0
l
January 3, 2010 5:59:55 PM

I got everything from Newegg but I bought them over several months as things went on sale. I decided that I ran a greater risk of shorting something out than getting a good reading when trying to test the PCI Express slot with the multimeter. Those pins were just way too small and close together. I decided that I would just replace both to be safe. Newegg sent me a new motherboard. I'm waiting to hear back from Rosewill to see what they can/will do for me. Thanks for your help with this Rolli.
m
0
l
!