Sign in with
Sign up | Sign in
Your question
Solved

HDD will not power internally but will through enclosure

Last response: in Storage
Share
December 6, 2011 6:48:49 AM

Hi everyone.

I just bought a new HDD purely for storage, not as a boot drive. It is the Samsung Spinpoint F3. When I installed it internally, my computer will not power up. The power flicks on for a moment but then dies. I then tried it in my enclosure for Sata HDD's which is connected via a USB cable. TO my surprise it worked fine through this and I managed to add it to my hard drives and format it in windows.

I then installed the drive again internally and the same problem. I have tried several different sata ports, a different sata cable, a different power cable.

The computer will power on if I unplug all other drives (2 SSD's) and leave the HDD plugged in but the drive does not spin up which is obvious due to the loud noise the spinpoint makes when it spins up.

The drive is set to slave.

The motherboard is an Asrock Z68 Extreme3 Gen4

Any help would be wonderful.

Thanks
December 7, 2011 5:23:15 AM

UPDATE: I've now tried the HDD in a separate computer internally as a slave drive and it works fine.
m
0
l

Best solution

a b G Storage
December 7, 2011 6:39:13 AM

What is your PSU?

I think you are running out of 12v or the 12v is bad.
Share
Related resources
a b G Storage
December 7, 2011 7:24:08 AM

I don't know Pyree. A new hard drive uses about 20 watts. An optical drive would use more power. And on boot up, the PSU is not under any kind of heavy 3D load.

Pyree said:
What is your PSU?

Jezzta, if you hang around here much, you will see that we are constantly asking for full computer specifications. Now you see why. :) 

Unplug your optical drive and use its data and power cables with the new hard drive. See the drive on something insulated (don't mount the drive in the bay). Then see what happens.

Next thing to check for is any difference in mounting the drive in the two cases. Maybe something is shorting when the drive is mounted in the first computer.
m
0
l
December 7, 2011 10:26:15 AM

Thanks a lot for the replies, guys. Pyree hit the nail on the head, though I discovered this through trial and error and have only just had a chance to get back to this thread.

I put the drive in another computer and it worked fine.

It ended up being a faulty 12v connector on my Antec HCP-850. If anything was plugged into it (including case fans) it would not power up. I ended up plugging in to other power ports. Its annoying because it's a reasonably expensive power supply and it's only a couple of months old. It's strange though because I'm sure I was using that port before.

Anyway, I hope this thread will help someone who has the same problem in future.
m
0
l
December 17, 2011 6:19:10 AM

Best answer selected by Jezzta667.
m
0
l
!