Sign in with
Sign up | Sign in
Your question

Disk read error on boot

Last response: in Storage
Share
December 6, 2011 1:47:03 PM

Hello,
I have a WD1200 and one of the connection broke. So I replaced the circuit board and now I get a disk read error. When I run it through my BlacX reader as an external HD it says it is not formatted, would you like to do it now. Any ideas?

More about : disk read error boot

December 6, 2011 2:04:32 PM

please can you give us further more detail?
m
0
l
December 6, 2011 2:50:51 PM

System is an older one, P4 - ASUS P4C800-E running XP Pro. The HD is 120GB Western Digital that operated fine. A friend was installing new cd/dvd for me and had the HD out and somehow broke part of the plastic on connection and then couldn't reconnect the cable and eventually broke a pin off. I bought a replacement pcb off ebay. All the numbers matched so it should be the right one. However, after installing pcb and booting up, it shows a disk read error occurred press ctrl+alt+del to restart. When i boot with my other HD and the WD in my HDD docking station and try to read it through windows explorer it says it needs to be formatted. (perhaps thats because it has the OS on it too) It shows up in the bios and if I run it through my notebook it shows up on computer management under storage/removable disk

Hope this is helpful information
m
0
l
December 7, 2011 6:36:56 PM

FYI - When I changed out the PCB I was not aware what all had had to match the old one. All the numbers on stickers and such matched, however I found out from Data Recovery Store that all the numbers on the chips themselves have to match. Otherwise the drive is toast. So I compared them on the chip side and one didn't match so my life has fried. So we can close this thread as the question has been solved
m
0
l
!