Sign in with
Sign up | Sign in
Your question

Pooched my Raid 0+1 - options?

Last response: in Storage
Share
December 7, 2011 5:01:33 PM

System was a 0+1 setup with 4 x 250Gb drives on a EVGA 780i MB with Nvidia raid controller. OS and all files were on these 4 drives. So it was 2 drives in raid 0 mirrored onto another 2 drives in raid 0.

I am wondering if my raid setup is lost now, or if it could be somehow restored. I am thinking of buying another harddrive to put the OS on and saving the 4 drives to be worked on, or if I should just get on and overwrite the original 4 drives.. what is the issue:

Yesterday I got in a new NAS server. The old one had about 250Gb of data on it I wanted to move as I wanted to re-use the drives in the new NAS server. SO, I looked on my main computer but it didn't have enough room to move the data. But, it was a raid 0+1 setup with 4 drives each 250 Gb. I thought if I could break the mirroring then I could gain the extra 500Gb and get the data off the NAS. I read around and it seemed like on boot, hit F10 there should be a way in the menu. Well there wasn't, just delete the array.. I thought after that step I could simply rebuild it if there wasn't the choice I wanted and be on my way if it wasn't possible. Of course it didn't go that way and it needed to be completely rebuilt. When I rebuilt it as the same 0+1 drive, it couldn't boot. So I used the windows recovery cd and tried to repair windows, but no drive seen..etc.. tried as much as I could thru recovery console and finally realized had to repartition it to be visible. So I just hit max partition like it used to be. After that, tried the fixmbr..etc..etc.. in command prompt to no avail. At this point I am sure I won't be able to get back the functioning system I had, so am at best looking at restoring data. I can probably live without it, but it would certainly make life easier and save hours of my time if I could get some of the directories back. After what I did, and this being 4 disks, is this a lost cause, or is there a way to recover it with software off another drive put in and win7 re-installed to work on these 4 drives? I guess I want to know if its worthwhile at this point to try, or save the cost of buying a 5th drive and just re-install over the old 4 if its hopeless.

More about : pooched raid options

December 7, 2011 5:22:37 PM

You may be able to resurrect the raid array by creating a new raid 0 and attaching it to the mirror setup. This will really depend on how "advanced" / "tolerant" you raid bios is. For future reference you would want to do a raid 1+0 aka a stripe of mirrors as this is much more fault tolerant.
m
0
l
December 7, 2011 5:28:05 PM

What's wrong with RAID 5?
m
0
l
Related resources
December 7, 2011 5:28:15 PM

wouldn't the original mirror now be overwritten as well when I deleted, then re-did the raid setup and repartition?

m
0
l
December 7, 2011 5:32:59 PM

Most likely however if you are able to get the raid setup in the exact same way as before and and you raid controller only initializes the raid metadata you might be able to make a recovery.
@one-shot raid 5 may work for his setup however for a southbridge "fake-raid" controller often write performance suffers dramatically
m
0
l
December 7, 2011 5:38:12 PM

Well after deleting I basically went back into the raid setup and re-created the 0+1 exactly as it was.. and hoped life would go on.. but it didn't. Would not boot. So that is when I went into win7 recovery/repair console and tried to rebuild mbr..etc. But it couldn't do anything because there was no longer a drvie C.. so I had to repartition the new array to get a drive C. I just hit default max size (the same as I would have years ago I am sure).. so now I have a drive C, but it is viewed as empty.
m
0
l
December 7, 2011 5:44:48 PM

p.s. it is Mediashield BIOS for raid. I just went back in to see what choices I have but don't know if I can do raid 5 as I cannot see those choices without deleting this again.. I can however chose to (R)ebuild the array. But its odd that I can only highlight one of the 4 drives. If I do that it warns 'all data on new (or added) disks will be overwritten. Continue?'.. Since all are basically new to the controller in a sense I would think, I am not sure what this will do. But if I hit 'yes', I get 'Array marked for rebuild, please boot to a supported OS/Driver to complete'.. I don't know what to do at that point since OS was on those drives...
m
0
l
December 7, 2011 5:51:27 PM

Yah looks like you data is toast. When you created the new partition windows automatically formats it. You may be able to use some form of a data recovery tool to get some of the data off the drive but as for restoring it to a bootable state is no longer possible. As long as you are now having to do a wipe now would be a good time to consider going raid 1+0 or raid 5 as these have a better tolerance to drive failure and recovery.
m
0
l
December 7, 2011 6:46:07 PM

At this point I thought the old OS was beyond repair and I would never be booting into it again. My only consideration is if any of the data on the drives could be recovered. If it can, I'll buy another drive to put an OS on and work on the drives.. if not, I might a well save the money and just start from scratch with these 4 drives. My choice if possible would be to recover some of the data if possible. But I am not sure if this is a hardcore thing a recovery company can only handle or if I could do it via some of the software options out there..
Wondering if software from companies like raidlabs.com would work, or not? ANyone have any experience down that road? I have emailed them the issue but have not heard back.
m
0
l
December 15, 2011 9:18:18 PM

Well I wanted to come back and give my results so anyone else stupid as I was can have hope. So here is what transpired:

Initially I was in a rush to set up my Qnap nas server to replace the dlink I had and tried to break my Raid 0+1 apart into 2 raid0 setups so I could use the one pair of drives to take data off of my old Nas. The bios software was very limited and I ended up delting the raid array. I recreated it the same (didn't move any of the cables around to change ports) by chosing the default drive order as I would have thought that was how it was originally done when I made the computer. I used a Windows 7 cd to try and repair the drive, but it would not see it. So I went and repartitioned it. After that, I could still not repair it. After posting here, I decided to go back into the bios as I had nothing really to lose thinking I had lost my data. I broke the raid, tried again to reconstruct it, and went to repair it through that software, but never followed through thinking that might be a more permanent destruciton. So I recreated back to raid 0+1 (as i had done many times already) as it was and tried out some of the software free trials.

The one above I mentioned found some files, but had them all jumbled into a single window. Now to be fair I didn't poke around the software much but it did not seem to have recovered much.. barely enough for me to consider purchasing. Also, with 4 or so versions of software (file recovery, partition recovery, raid recovery..etc..etc) I was not sure which one to get, and they never responded to my email. I went to other websites to look at software, and found pretty well the same 4 packages, but different names.. upon running the interfaces seemed almost identical so I got the feeling whomever is selling that software has the same thing under multiple names.. which gave me some red flags.

So I continued to look around and found something called 'active@file recovery for windows'. They have a partition recovery and raid recovery as well. I was not sure what to try so I tried the partition recovery but was not exactly sure what I was seeing, or what I should do so I decided against doing anything. The file recovery however was fairly straight forward. It took a looong time to do a surface scan (over night). I was surprised in the morning to see a list of boots and local disks that it had found and listed in order of quality. I went into the disk that had the best quality and to my amazement saw the entire directory structure identical as to what I had it.. the software shows it like a standard explorer directory tree. I made the mistake though of clicking on 'recover' after highlighting the drive. I am not sure why, but it may have been every time I rebuilt the raid certain files got duplicated and erased..most of them.. like 7 or 8 times.. so just clicking on restore would restore all these versions of the same file (all the deleted copies as well) and be a massive restore. But under 'view' there is 'existing files/folders' that if you click on only shows the existing files and not all those deleted ones so you can recover only those. I quickly paid the 34$ and and upgraded to restore. And I am pleased to say absolutely every file is back and intact... amazing after all I did to the drives.

Since the directory is so intact, i'm not sure why I couldn't make this bootable again.. maybe will mess around and see what I can do now data is saved.
m
0
l
!