Sign in with
Sign up | Sign in
Your question

WIth CPU upgrade, half of RAM not detected

Last response: in Memory
Share
July 18, 2010 2:03:31 AM

I have:

Biostar TA770 A2+ using the latest BIOS (C25 from the Biostar China website)
4x1GB G.Skill DDR2 800 RAM
AMD Athlon X2 7850 Black Edition

My problem is, I can't get the BIOS to see more than 2GB of memory. All of my ram used to work just fine until I upgraded the CPU from an Athlon X2 4000+ to the 7850. Everything else works perfectly, computer boots, all overclock options work, etc except for the lack of RAM. The four sticks are perfectly matched, and have worked in my system for a couple of years without issue.

I've tried everything I can think of from moving sticks of ram around, different combinations of sticks, tried reseating the CPU, checked for bent pins (none found), upgraded the BIOS to latest, played with ram voltages and timings (most of which make the board fail to POST). In full disclosure, this is a hackintosh system, and in the system profiler isn't showing my ram as having two sticks of 512 MB and two 1 GB sticks. I'm running 10.6.4 in 32-bit mode but I don't think that would matter because it's always been in 32-bit and always showed the full 4GB before the CPU upgrade.

My only other thoughts are that I know there is some issue with Phenoms (which the 7850 is, essentially) in some motherboards only working with one stick of ram in each channel. However that's supposedly with DDR2 1066 memory and the fact that the Mac OS system profiler is showing the other two sticks working at half capacity makes me think there is issue somewhere else. In my tests with just using two stick of RAM, only half of the memory is being detected as well rather than the full 2GB so the problem isn't just with using four sticks.

As an added note, all timings at on auto detect, s 5-5-5-15 2T, etc, running unganged mode).

I don't really want to throw another $90-$100 at this system for 2x2GB of RAM in order to get back to my 4GB total. Does anyone have any ideas that may help with my situation?

Thanks in advance for any input.
a c 128 } Memory
a c 159 à CPUs
July 18, 2010 10:29:03 AM

Cpuz may recognize your ram. 7850 is not a good cpu. I would go with the regor 250 or the 550. buying more ram won't solve your problem; 4 gigs is enough.
m
0
l
July 18, 2010 4:53:34 PM

do a fresh clean OS reinstall. second, what is the point of hackintosh? Win7 blows away OS-x
m
0
l
Related resources
a b } Memory
a b à CPUs
July 18, 2010 5:00:37 PM

Funky. Contact BioStar support to see if they have nay info on this. It may just be a case of the board not really liking the RAM too much :D . If that's not it you could have a CPU with a bad memory controller, in which case you need to RMA it :D 
m
0
l
a b } Memory
a b à CPUs
July 18, 2010 5:01:16 PM

Have you tested the ram? memtest86?
m
0
l
!