Sign in with
Sign up | Sign in
Your question
Solved

Can't see hard drive in computers folder

Last response: in Storage
Share
December 9, 2011 1:37:20 AM

Hi.
I had an internet problem with windows 7 ultimate 64bit, so i decided to format it. I had one windows drive (SAMSUNG 250GB) and one storage drive (HITACHI 1TB) which has 900GB of important data on it. I chose custom installation onto my old windows drive (samsung) and it installed with no problems. I didn't touch my other drive. now, i can't see my 1tb storage drive in computers or in drive manager, but i can still see it in device manager! What should i do?? i really don't want to format it, but if the data is gone then i will have to. :( 

Best solution

a b G Storage
December 9, 2011 1:48:10 AM

Hello,

Did you try connecting your storage drive to another computer and see if that shows there.
Does this drive show in BIOS
Did you check Disk Management (Right click on Computer >> Manage >> Disk Management) - If this drive doesn't have a letter assigned to it, you may assign a letter and it should be visible.
Share
December 9, 2011 2:21:27 AM

I tried the 3rd option and it worked!!! but now i have new problem: i can't install games or anything onto the harddrive. they say something like: can't create file. but, i can paste files into it. what's going on?
m
0
l
Related resources
a b G Storage
December 9, 2011 2:32:31 AM

I am glad Option 3 worked for you.

This new problem is weird.
Try to reboot and install as administrator - just a thought!!
m
0
l
December 9, 2011 2:34:54 AM

i did. by the way i haven't formatted my hard drive. i don't know whether that matters or not, and i hope it doesn't because there's 400 gb of stuff in there that i don't wanna lose!

by the way it didn't work
m
0
l
November 10, 2012 5:04:19 PM

Best answer selected by peyman_tp.
m
0
l
August 21, 2013 3:11:54 PM

I just built a new PC and I am having the same issue. I assigned a letter to my new 2TB HDD but windows will not allow me to format it. In addition, it says the disc capacity if only 100MB (viewing from My Computer folder).
m
0
l
!